summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:50:04 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:50:04 +0100
commitd17b8361aa3cbaa5b84934c9762ad286f725e6b4 (patch)
treee9da7a3bf88cf80469ea5810c515dbb7319b18af
parentdev-python/spyder cleanup old (diff)
downloadgentoo-d17b8361aa3cbaa5b84934c9762ad286f725e6b4.tar.gz
gentoo-d17b8361aa3cbaa5b84934c9762ad286f725e6b4.tar.bz2
gentoo-d17b8361aa3cbaa5b84934c9762ad286f725e6b4.zip
dev-python/spyder-kernels: cleanup old
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/spyder-kernels/spyder-kernels-1.10.2.ebuild48
-rw-r--r--dev-python/spyder-kernels/spyder-kernels-2.0.5.ebuild53
-rw-r--r--profiles/package.mask7
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-python/spyder-kernels/spyder-kernels-1.10.2.ebuild b/dev-python/spyder-kernels/spyder-kernels-1.10.2.ebuild
deleted file mode 100644
index e158e9fa6068..000000000000
--- a/dev-python/spyder-kernels/spyder-kernels-1.10.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Kernels used by spyder on its ipython console"
-HOMEPAGE="https://github.com/spyder-ide/spyder-kernels/
- https://pypi.org/project/spyder-kernels/"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}-gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-5.3.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.6.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
- >=dev-python/wurlitzer-1.0.3[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/xarray[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # requires dask[distributed] while we last-rited distributed
- sed -i -e 's:test_dask_multiprocessing:_&:' \
- spyder_kernels/console/tests/test_console_kernel.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/spyder-kernels/spyder-kernels-2.0.5.ebuild b/dev-python/spyder-kernels/spyder-kernels-2.0.5.ebuild
deleted file mode 100644
index 6e20169fd3b2..000000000000
--- a/dev-python/spyder-kernels/spyder-kernels-2.0.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Kernels used by spyder on its ipython console"
-HOMEPAGE="https://github.com/spyder-ide/spyder-kernels/
- https://pypi.org/project/spyder-kernels/"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}-gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-5.3.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.6.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
- dev-python/matplotlib-inline[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
- >=dev-python/wurlitzer-1.0.3[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/dask[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/xarray[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # we no longer package distributed
- spyder_kernels/console/tests/test_console_kernel.py::test_dask_multiprocessing
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index da8d79cab7a9..830b20510b3b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -290,13 +290,6 @@ net-analyzer/jmx2munin
# Removal on 2022-01-31, bug #547208
sys-cluster/mpich2
-# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2022-01-08)
-# Ancient versions of spyder preventing clean up of things down the tree.
-# Sadly, this means we are also going to have to say goodbye to some plugins
-# that never got ported to the newer plugin system.
-# Removal in 15 days
-<dev-python/spyder-kernels-2.1.0
-
# Brian Evans <grknight@gentoo.org> (2022-01-07)
# The main consumer, phpunit, does not initiate the new timer correctly
# This is likely to cause issues in tests; Unmask if using for other purposes