summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-12 19:34:57 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-12 19:39:53 +0100
commitdea08d5365f3466025054629e926d325dd7a80ae (patch)
tree39492a239b200092c9087b42bc39572334a739b3
parentdev-python/poetry: Bump to 2.0.1 (diff)
downloadgentoo-dea08d5365f3466025054629e926d325dd7a80ae.tar.gz
gentoo-dea08d5365f3466025054629e926d325dd7a80ae.tar.bz2
gentoo-dea08d5365f3466025054629e926d325dd7a80ae.zip
dev-python/poetry-plugin-export: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/poetry-plugin-export/Manifest1
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.9.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
index 714b3ff1162b..5f6d29563eca 100644
--- a/dev-python/poetry-plugin-export/Manifest
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -1,2 +1,3 @@
DIST poetry_plugin_export-1.7.1.tar.gz 29656 BLAKE2B 130eb35064104c3f22958816447ff674d1f5aed657ada2fe23a635de52338cb736f631b622b0641aae308d69494eb939a1ea659e33fc6227bb742ee01335ae15 SHA512 d472d8e4d6eb803587722854be912009a9bc0a8f86ee0e3ef0046f385ed59236af229109dae85198e3a205702cff86780576939e518fa797f3e5093537a0d2f1
DIST poetry_plugin_export-1.8.0.tar.gz 29840 BLAKE2B 67748605964f90120be8a696b454497e53f9ff8c739a09930e31fef19623f05552b069a5c572a1a32a0ad68ee85e760901f61bfdf8ba35351b982863e250d4ed SHA512 90cbf0e79787611a4d78c6ce637d4087d375aa25e65489d770d13f2a769d9919d76512b3fad70073073a83fe41ec42a8925c8b27983d84458007356b3ec8409d
+DIST poetry_plugin_export-1.9.0.tar.gz 30835 BLAKE2B f8f7649d0bcec78bb0c2279204d7279c6c7d1d32e9f2d76b45e5a9fe817924ccbfc61ca6da13e151e5b1c45e2974d1cdf25214b1e9e550a2595efa386c2a1784 SHA512 5c2c5d6bca5832d17083fa568d7974e16ec66010a0dc05aca66d090ed12ce1a1645ed29ce072cbe156315b54e77906b4e723101c6206aa1fbc1e64295a2a8da5
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.9.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.9.0.ebuild
new file mode 100644
index 000000000000..f8206b459303
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.7.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/poetry-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest