summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-05-02 01:41:32 +0300
committerMart Raudsepp <leio@gentoo.org>2019-05-02 01:42:30 +0300
commit44f25e22e07a4b11a185ed086f51872bd9febe19 (patch)
tree9a5b87ca21e0644027ddc09eea048a4d96bd837e /app-accessibility/edbrowse
parentdev-libs/gjs: remove old (diff)
downloadgentoo-44f25e22e07a4b11a185ed086f51872bd9febe19.tar.gz
gentoo-44f25e22e07a4b11a185ed086f51872bd9febe19.tar.bz2
gentoo-44f25e22e07a4b11a185ed086f51872bd9febe19.zip
app-accessibility/edbrowse: bump to 3.7.4
Uses duktape instead of old mozjs/spidermonkey version. Ported to use new cmake system. Hopefully fixing the two edbrowseodbc bugs along the way (not tested). Closes: https://bugs.gentoo.org/632632 Closes: https://bugs.gentoo.org/638722 Closes: https://bugs.gentoo.org/556924 Closes: https://bugs.gentoo.org/625334 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-accessibility/edbrowse')
-rw-r--r--app-accessibility/edbrowse/Manifest1
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.7.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-accessibility/edbrowse/Manifest b/app-accessibility/edbrowse/Manifest
index 1405c4877352..ab7c37f33f7a 100644
--- a/app-accessibility/edbrowse/Manifest
+++ b/app-accessibility/edbrowse/Manifest
@@ -1 +1,2 @@
DIST edbrowse-3.5.1.zip 745277 BLAKE2B 2256faf58de68ab2d19d3137ddaaa92dbfdfff581d83c9f2b58e0e161c10aaa5c867dbf8b81da77f21abdd5c1a07d882abafff4bcfc0706fc33a73b7ba6bc087 SHA512 83bdb1d49afa04a41a84b71e86969880b518d8d6c1e448380d70710ad2373ed57cb3699d3ad50226ea4d5776f511ff50b9510655b27d26948213113699512fc2
+DIST edbrowse-3.7.4.tar.gz 765794 BLAKE2B 5d428ca3923e26d5b3f204d5aba37a08bbfc50345b18718e5a281521361da4920ea12d68a5013bb688e95f178be8903bede1bef5b3cd626a0e6084141188d878 SHA512 79b2b450b6f54f3d74b7c722f223b3340b3ddfa1cbff2d69adcd1cd4ffb76b78a812a35a053cf224a74543020ef8423cd68eafa9a277451245d383065fb1595d
diff --git a/app-accessibility/edbrowse/edbrowse-3.7.4.ebuild b/app-accessibility/edbrowse/edbrowse-3.7.4.ebuild
new file mode 100644
index 000000000000..91fd4cd8a6e6
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="Combination editor, browser, and mail client that is 100% text based"
+HOMEPAGE="http://edbrowse.org"
+SRC_URI="https://github.com/CMB/edbrowse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="odbc"
+
+RDEPEND="
+ app-text/tidy-html5
+ >=net-misc/curl-7.36.0
+ >=dev-libs/libpcre-7.8
+ >=sys-libs/readline-6.0
+ dev-lang/duktape
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s:/usr/share/doc/edbrowse:/usr/share/doc/${P}:" CMakeLists.txt
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EDBR_ODBC=$(usex odbc)
+ )
+ cmake-utils_src_configure
+}