summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-09 22:24:58 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-09 22:24:58 +0900
commit942e97f4b4255da0a9e59a2d3164ce9da22ed5a7 (patch)
treed1371880931220f95b09fb0c20110fa6962a8ecb /app-editors/aee
parentapp-editors/aee: update to EAPI 6 (diff)
downloadgentoo-942e97f4b4255da0a9e59a2d3164ce9da22ed5a7.tar.gz
gentoo-942e97f4b4255da0a9e59a2d3164ce9da22ed5a7.tar.bz2
gentoo-942e97f4b4255da0a9e59a2d3164ce9da22ed5a7.zip
app-editors/aee: fix build with -Werror=format-security
Gentoo-Bug: 521012 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-editors/aee')
-rw-r--r--app-editors/aee/aee-2.2.15b.ebuild5
-rw-r--r--app-editors/aee/files/aee-Wformat-security.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
index 3610053fa695..bbd9266d8086 100644
--- a/app-editors/aee/aee-2.2.15b.ebuild
+++ b/app-editors/aee/aee-2.2.15b.ebuild
@@ -18,7 +18,10 @@ IUSE="X"
RDEPEND="X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-ae-location.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-ae-location.patch
+ "${FILESDIR}"/${PN}-Wformat-security.patch
+)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
src_prepare() {
diff --git a/app-editors/aee/files/aee-Wformat-security.patch b/app-editors/aee/files/aee-Wformat-security.patch
new file mode 100644
index 000000000000..7bc4c9c39fa1
--- /dev/null
+++ b/app-editors/aee/files/aee-Wformat-security.patch
@@ -0,0 +1,11 @@
+--- a/aee.c
++++ b/aee.c
+@@ -2493,7 +2493,7 @@
+ }
+ if (shell_fork)
+ {
+- printf(press_ret_to_cont_str);
++ printf("%s", press_ret_to_cont_str);
+ fflush(stdout);
+ while (((in = getchar()) != '\n') && (in != '\r'))
+ ;