summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-25 21:41:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-26 15:11:34 +0200
commit9bc83ae62274e769e46a5b4c052023fb2e1d4bc5 (patch)
tree99486d8543ce36334358babb1234a7fafe138f56 /app-emacs/emacs-ebuild-snippets
parentapp-emacs/emacs-ebuild-snippets: bump to 2.2.0 (diff)
downloadgentoo-9bc83ae62274e769e46a5b4c052023fb2e1d4bc5.tar.gz
gentoo-9bc83ae62274e769e46a5b4c052023fb2e1d4bc5.tar.bz2
gentoo-9bc83ae62274e769e46a5b4c052023fb2e1d4bc5.zip
app-emacs/emacs-ebuild-snippets: sync live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emacs-ebuild-snippets')
-rw-r--r--app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild b/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild
index ad9c1efeb7b0..d4ecac40855b 100644
--- a/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild
+++ b/app-emacs/emacs-ebuild-snippets/emacs-ebuild-snippets-9999.ebuild
@@ -8,11 +8,13 @@ inherit elisp
DESCRIPTION="Yasnippets for editing ebuilds and eclasses"
HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-ebuild-snippets.git"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
else
SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
@@ -23,7 +25,9 @@ RDEPEND="
app-emacs/ebuild-mode
app-emacs/yasnippet
"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+"
src_prepare() {
sh ./scripts/changeme.sh "${EPREFIX}${SITEETC}/${PN}" || die
@@ -32,8 +36,8 @@ src_prepare() {
}
src_install() {
- elisp-install ${PN} *.el{,c}
- elisp-site-file-install "${S}"/gentoo/50${PN}-gentoo.el
+ elisp-install "${PN}" *.el{,c}
+ elisp-site-file-install "${S}/gentoo/50${PN}-gentoo.el"
insinto "${SITEETC}/${PN}"
doins -r snippets