summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 01:27:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-20 01:32:29 +0200
commit300bdfc29fd3673a2324e729191f72c39c52f282 (patch)
tree8643dca4dedb3e255d50f2dd9bea46b6039a4008 /app-emacs
parentapp-emacs/magit: drop libgit IUSE and remove libegit support (diff)
downloadgentoo-300bdfc29fd3673a2324e729191f72c39c52f282.tar.gz
gentoo-300bdfc29fd3673a2324e729191f72c39c52f282.tar.bz2
gentoo-300bdfc29fd3673a2324e729191f72c39c52f282.zip
app-emacs/magit: bump to 3.3.0.50_p20240520
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-3.3.0.50_p20240520.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index 0bab74cb042f..ecb58be44865 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1 +1,2 @@
DIST magit-3.3.0.50_p20230912.tar.gz 666150 BLAKE2B 52d0afa05fad68283c668810806a61e3df6494c8afecdceccf193c64eec5396fb5f45fad5c31d4cb601954c8abc27fcc4be240ffd72c4fc72531876657c4c157 SHA512 d6c8c32676b07253b661388e8db1602162f7012ff3bf5bc6bcc071507bb9c08633359043eb893b743e5f37d7474a17b1a2e96975cd64d0688e3c6337ca65470e
+DIST magit-3.3.0.50_p20240520.tar.gz 673945 BLAKE2B d61fb8c566de2bc6a2c4109d787808be76fa33d994adeb97b3d472c9c2da929aa55cf6b81f9cc2055e46d5860aa0d9ddc37080a1b2be06984b3831382031b12b SHA512 53203cdc8bc291302ee35aabe6e4d32e0c0de5bb411ab013d112bcd3d934a221c34f42d6ebccea9d33335d53415f75588468c23668cbbf57851dc61de505fffb
diff --git a/app-emacs/magit/magit-3.3.0.50_p20240520.ebuild b/app-emacs/magit/magit-3.3.0.50_p20240520.ebuild
new file mode 100644
index 000000000000..40c3863eb285
--- /dev/null
+++ b/app-emacs/magit/magit-3.3.0.50_p20240520.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/magit.git"
+ S="${WORKDIR}/${P}/lisp"
+else
+ [[ "${PV}" == *p20240520 ]] && COMMIT="9cde118744151caca08b080e15f0c903f17d0f20"
+
+ SRC_URI="https://github.com/magit/magit/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}/lisp"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.5
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.6.0
+ >=app-emacs/with-editor-3.3.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.0.0
+"
+
+src_prepare() {
+ default
+
+ rm magit-libgit.el || die
+ echo "(setq magit-version \"${PV}\")" > ./magit-version.el || die
+}