summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-02-18 08:31:23 +0100
committerUlrich Müller <ulm@gentoo.org>2019-02-18 08:33:18 +0100
commita6169ecf978a3e98c4ae9f35a1274890e3e9e289 (patch)
tree87fa9788eeed1aaaaea6e867ba1cdd6def1f5303 /app-emacs
parentdev-python/dexml: amd64 stable wrt bug #676274 (diff)
downloadgentoo-a6169ecf978a3e98c4ae9f35a1274890e3e9e289.tar.gz
gentoo-a6169ecf978a3e98c4ae9f35a1274890e3e9e289.tar.bz2
gentoo-a6169ecf978a3e98c4ae9f35a1274890e3e9e289.zip
app-emacs/rust-mode: New snapshot.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/rust-mode/Manifest1
-rw-r--r--app-emacs/rust-mode/rust-mode-0.3.0_p20190125.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/Manifest b/app-emacs/rust-mode/Manifest
index 7124a79e94de..bf6e5bf65b78 100644
--- a/app-emacs/rust-mode/Manifest
+++ b/app-emacs/rust-mode/Manifest
@@ -1 +1,2 @@
DIST rust-mode-0.3.0_p20180221.tar.xz 37392 BLAKE2B 185511a2096400254e141f213f2e9a84861c2aaf5f2259cab724aa929e07b2691ae6f36c5568de5d978809588271486377a194a77a066413df6ee995e9bbe54a SHA512 004bd1536ab2e1e708193509a307ed47e22bf1f3dc5d84816958588e312c8bf6e75ee178cc99439ec0bd427ba02030c133bb21f96c5116b175d1d7cde89e9e6c
+DIST rust-mode-0.3.0_p20190125.tar.xz 37580 BLAKE2B d4d3ae9dac452ba3e2966d5036bd5f4edb4066ca65954b7f18a99c56ad6a8848fd80ef799c7c266c77a844839d87ab9641c77afc089a17e4e459fea27b6af982 SHA512 303d7f183006769b3fdf7a7118b36d29d785c2a29cf88ae286cb86180f84a4e50e66597d3bc984979e2509b872632d750fba96ff522081df5351d8d9511a3272
diff --git a/app-emacs/rust-mode/rust-mode-0.3.0_p20190125.ebuild b/app-emacs/rust-mode/rust-mode-0.3.0_p20190125.ebuild
new file mode 100644
index 000000000000..08710c7798e1
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-0.3.0_p20190125.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="https://github.com/rust-lang/rust-mode"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l rust-mode.el -l rust-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} rust-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}