summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-15 23:59:17 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-16 00:23:29 +0200
commita95d450c5ba72cc6244031c6d0c1b6d2610f6b3d (patch)
tree3c6064cd112747f7ffc78976ae3dae45d5c6bc35 /app-emacs
parentapp-emacs/ebib: drop old 2.40.5 (diff)
downloadgentoo-a95d450c5ba72cc6244031c6d0c1b6d2610f6b3d.tar.gz
gentoo-a95d450c5ba72cc6244031c6d0c1b6d2610f6b3d.tar.bz2
gentoo-a95d450c5ba72cc6244031c6d0c1b6d2610f6b3d.zip
app-emacs/ebib: bump to 2.42
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ebib/Manifest1
-rw-r--r--app-emacs/ebib/ebib-2.42.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/ebib/Manifest b/app-emacs/ebib/Manifest
index 8ca4323ccf2a..8436ad51a12c 100644
--- a/app-emacs/ebib/Manifest
+++ b/app-emacs/ebib/Manifest
@@ -1 +1,2 @@
DIST ebib-2.41.1.tar.gz 1048824 BLAKE2B 1746f782f3445e0d2bfb9cd9b62273b95afd4dc0e940943ba57f7e3b7855c4e1e174d9255d41a2829ad8f43bbbd04142da3c70a9afeb4ad467ecb7542215bcd9 SHA512 2b948b2381680779b68ab7015b1a840ac8437b63ae9a74a157d7b9beb37105eb1a12d170302e8000879233aaedb103006d4b31967f9b923d8879ff03c3f1c97b
+DIST ebib-2.42.tar.gz 1051129 BLAKE2B 2ae2b523c271b1bc8d6376d48519dcf3dfd0c5df1673625c90728ceeeaf148d39e779142733ce3d390087907c51ecc9fe50bb2399111ac8dcf6de7b6a9b6ccd2 SHA512 1c937cada22f5c59ea8e5f26ce88a084a3824b153ac5f78e34c0702f72628f6e96dc5672b1f0cf307413880e578744a07591907de468f6992813205d50ad61ed
diff --git a/app-emacs/ebib/ebib-2.42.ebuild b/app-emacs/ebib/ebib-2.42.ebuild
new file mode 100644
index 000000000000..688763487ce1
--- /dev/null
+++ b/app-emacs/ebib/ebib-2.42.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/ebib/
+ https://github.com/joostkremers/ebib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.4
+ app-emacs/parsebib
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/with-simulated-input
+ )
+"
+
+DOCS=( README.md docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}