summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-29 07:01:46 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-29 07:13:18 -0500
commite2f4a3f59827dbb84f7935ddbe170e7ed5947462 (patch)
tree612b2442928832b6eea7601e1b2e68cf1bf90894 /app-emulation
parentprofiles: Remove mask for app-admin/helm (diff)
downloadgentoo-e2f4a3f59827dbb84f7935ddbe170e7ed5947462.tar.gz
gentoo-e2f4a3f59827dbb84f7935ddbe170e7ed5947462.tar.bz2
gentoo-e2f4a3f59827dbb84f7935ddbe170e7ed5947462.zip
app-emulation/dxvk: update live
Roughly anyway, this will need more attention. Ideally hoping upstream will provide some better options than raw instructions to the removed setup_dxvk.sh, or may have to make our own one given this is rather annoying to handle manually. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dxvk/dxvk-9999.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/app-emulation/dxvk/dxvk-9999.ebuild b/app-emulation/dxvk/dxvk-9999.ebuild
index 19174e20a451..167b7c5d6901 100644
--- a/app-emulation/dxvk/dxvk-9999.ebuild
+++ b/app-emulation/dxvk/dxvk-9999.ebuild
@@ -12,14 +12,18 @@ if [[ ${PV} == 9999 ]]; then
EGIT_SUBMODULES=(
# picky about headers and is cross-compiled making -I/usr/include troublesome
include/{spirv,vulkan}
+ subprojects/libdisplay-info
)
else
HASH_SPIRV=0bcc624926a25a2a273d07877fd25a6ff5ba1cfb
HASH_VULKAN=98f440ce6868c94f5ec6e198cc1adda4760e8849
SRC_URI="
- https://github.com/doitsujin/dxvk/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/KhronosGroup/SPIRV-Headers/archive/${HASH_SPIRV}.tar.gz -> ${PN}-spirv-headers-${HASH_SPIRV::10}.tar.gz
- https://github.com/KhronosGroup/Vulkan-Headers/archive/${HASH_VULKAN}.tar.gz -> ${PN}-vulkan-headers-${HASH_VULKAN::10}.tar.gz"
+ https://github.com/doitsujin/dxvk/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Headers/archive/${HASH_SPIRV}.tar.gz
+ -> ${PN}-spirv-headers-${HASH_SPIRV::10}.tar.gz
+ https://github.com/KhronosGroup/Vulkan-Headers/archive/${HASH_VULKAN}.tar.gz
+ -> ${PN}-vulkan-headers-${HASH_VULKAN::10}.tar.gz"
KEYWORDS="-* ~amd64 ~x86"
fi
@@ -67,8 +71,6 @@ src_prepare() {
fi
default
-
- sed -i "/^basedir=/s|=.*|=${EPREFIX}/usr/lib/${PN}|" setup_dxvk.sh || die
}
src_configure() {
@@ -116,7 +118,6 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- dobin setup_dxvk.sh
dodoc README.md dxvk.conf
find "${ED}" -type f -name '*.a' -delete || die
@@ -127,13 +128,15 @@ pkg_preinst() {
}
pkg_postinst() {
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "To enable ${PN} on a wine prefix, you can run the following command:"
- elog
- elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
- elog
- elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
- elif [[ -v DXVK_HAD_OVERLAY ]]; then
+ # TODO: setup_dxvk.sh script was removed, need to figure out a new way to
+ # explain/handle (leaving this alone for now in live in case gets restored)
+# if [[ ! ${REPLACING_VERSIONS} ]]; then
+# elog "To enable ${PN} on a wine prefix, you can run the following command:"
+# elog
+# elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
+# elog
+# elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
+ if [[ -v DXVK_HAD_OVERLAY ]]; then
# temporary warning until this version is more widely used
elog "Gentoo's main repo ebuild for ${PN} uses different paths than most overlays."
elog "If you were using symbolic links in wine prefixes it may be necessary to"