summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2023-02-08 21:17:06 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-02-15 16:21:14 +0200
commit4f5167bdf986d6b006ff8c3fe48d5a1f3e06158f (patch)
tree70a5e69d1fc326488e17098ef0fc9fb264e3d82b /app-i18n
parentsys-kernel/gentoo-sources: stabilize 6.1.12 for x86 (diff)
downloadgentoo-4f5167bdf986d6b006ff8c3fe48d5a1f3e06158f.tar.gz
gentoo-4f5167bdf986d6b006ff8c3fe48d5a1f3e06158f.tar.bz2
gentoo-4f5167bdf986d6b006ff8c3fe48d5a1f3e06158f.zip
app-i18n/translate-shell: bump version to 0.9.7.1
Signed-off-by: Ferenc Erki <erkiferenc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29304 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/translate-shell/Manifest1
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/Manifest b/app-i18n/translate-shell/Manifest
index c4dafb0f9629..da1236c6c30f 100644
--- a/app-i18n/translate-shell/Manifest
+++ b/app-i18n/translate-shell/Manifest
@@ -1,2 +1,3 @@
DIST translate-shell-0.9.6.11.tar.gz 76779 BLAKE2B 39748d0a2d7db504fd4c0bee516f703291dce93f19aa760fdae70b0551cb5f14ae5483314114f7e1141ae2231e0b128a79a9c05ec1fd08c970be886c4430e32d SHA512 d4d376b3750e43e3de5b95790fea7fc91e94140526ac15ee9f7818554f95d410772c8f8887433b6fd4547f569b3d6f510c1bc1497d8237223c344dbb8f0ae87f
DIST translate-shell-0.9.6.12.tar.gz 77580 BLAKE2B 78e8c694edc03fb03facd8c705c7e703a106fe9f2d7b46d464a681d52523817b4aeaf023fdedf46a9792270daf758fde457ba30ab1ffaa778f8db3eba3caa892 SHA512 6cbdfd14b7004d0e37a4abee01bec87409137f1bb7a14a964936bf0a2ad704ea1fc04dcd8ab10404a5c2df105bf7a6a8b33ed02c75c1035a6900082f6dfbb20d
+DIST translate-shell-0.9.7.1.tar.gz 94865 BLAKE2B a64bf33d2c4e79889854c427cf5853b5a58ae0478ef51f2ca4b7eb481cc74a06ba33537bc9a557694e1b6a3c585328c73f4aec75d4e941a8d695bc18dd03b096 SHA512 d25a6177ee5b9d41715042b653ad345d1c76884423700f0fe53bc2ffddd6d3c14844fa4e768b87b055018794a8c4057c329810c65764e7f9aa425ceac35f0810
diff --git a/app-i18n/translate-shell/translate-shell-0.9.7.1.ebuild b/app-i18n/translate-shell/translate-shell-0.9.7.1.ebuild
new file mode 100644
index 000000000000..cea089af6a72
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/gawk"
+DEPEND="${RDEPEND}
+ test? (
+ app-editors/emacs
+ app-misc/rlwrap
+ )"
+
+src_test() {
+ emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}
+
+pkg_postinst() {
+ optfeature "all built-in translators (e.g. Apertium, Yandex)" net-misc/curl[ssl]
+ optfeature "display text in right-to-left scripts" dev-libs/fribidi
+ optfeature "text-to-speech functionality" media-sound/mpg123 app-accessibility/espeak media-video/mpv media-video/mplayer
+ optfeature "interactive translation (REPL)" app-editors/emacs app-misc/rlwrap
+ optfeature "spell checking" app-text/aspell app-text/hunspell
+}