summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-01-05 12:32:19 +0800
committerYixun Lan <dlan@gentoo.org>2024-01-11 00:19:57 +0000
commite935a9f905755aee27fd8b221b878655ac58257b (patch)
tree0402d5a24a8e2c5bffbaeb5e8abb8904bf8555e6 /app-i18n
parentapp-i18n/fcitx: add 5.1.6 (diff)
downloadgentoo-e935a9f905755aee27fd8b221b878655ac58257b.tar.gz
gentoo-e935a9f905755aee27fd8b221b878655ac58257b.tar.bz2
gentoo-e935a9f905755aee27fd8b221b878655ac58257b.zip
app-i18n/fcitx-qt: add 5.1.4
qt6 doas not depend on X in fcitx-qt. So add X use to make it optional. Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-qt/Manifest1
-rw-r--r--app-i18n/fcitx-qt/fcitx-qt-5.1.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt/Manifest b/app-i18n/fcitx-qt/Manifest
index 36a15ecbc431..461fde3dae41 100644
--- a/app-i18n/fcitx-qt/Manifest
+++ b/app-i18n/fcitx-qt/Manifest
@@ -1 +1,2 @@
DIST fcitx-qt-5.1.3.tar.xz 92312 BLAKE2B 84dda11e955ab1317379e0f5a0e95efb1b3108844b52c0e8fd08a02f0d5d6d16094c8729820ad7dce51e3d77994c217710f69edff4d566251f9272a125ffc936 SHA512 7d02409ac8359cea5e199f16b3b06ecfe47886edb00bb2163f9fbe1c319bbef425387e58db25fdfcd2b35261eada35f2acfb93ff0b65ed497da62d35363e8947
+DIST fcitx-qt-5.1.4.tar.xz 92880 BLAKE2B b165740e173fe21e8953b5605713c0250265e4906c25a56c5320f2560d261a9b8d4111f0960287b08fa7ac18c917d0da737fb1022bba7f76ca2e2e00d2d4f060 SHA512 942999327415e3d4195c18c2fb02e12a313e3a2cf1dd1e32d0e6a7a98b625bcc1b3a7278934bb583a029dee43a271dba9bac75face42729249557f60e1146adf
diff --git a/app-i18n/fcitx-qt/fcitx-qt-5.1.4.ebuild b/app-i18n/fcitx-qt/fcitx-qt-5.1.4.ebuild
new file mode 100644
index 000000000000..8a63118949cc
--- /dev/null
+++ b/app-i18n/fcitx-qt/fcitx-qt-5.1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-qt"
+
+inherit cmake
+
+DESCRIPTION="Qt library and IM module for fcitx5"
+HOMEPAGE="https://github.com/fcitx/fcitx5-qt"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="+qt5 onlyplugin staticplugin qt6 +X wayland"
+REQUIRED_USE="
+ || ( qt5 qt6 )
+ qt5? ( X )
+ staticplugin? ( onlyplugin )
+"
+
+RDEPEND="
+ !onlyplugin? (
+ >=app-i18n/fcitx-5.1.5:5
+ qt5? ( dev-qt/qtconcurrent:5 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ wayland? ( dev-qt/qtwayland:5 )
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus,gui,widgets,wayland?]
+ wayland? ( dev-qt/qtwayland:6 )
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+ !onlyplugin? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT4=no
+ -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT6=$(usex qt6)
+ -DENABLE_QT6_WAYLAND_WORKAROUND=$(usex qt6 $(usex wayland))
+ -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
+ -DBUILD_STATIC_PLUGIN=$(usex staticplugin)
+ )
+ cmake_src_configure
+}