summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-12 13:56:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-18 08:51:23 +0200
commit206356bcbe465d0996fe8d04fb2e15551ca0f6f0 (patch)
tree9eda147459078e0194e85564ef38c9e35a970adf /app-misc/fujiplay
parentdev-python/py-amqp: remove unused patch(es) (diff)
downloadgentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.tar.gz
gentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.tar.bz2
gentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.zip
app-misc/fujiplay: EAPI7, fix HOMEPAGE/SRC_URI, improve ebuild
Closes: https://bugs.gentoo.org/665772 Closes: https://github.com/gentoo/gentoo/pull/9843
Diffstat (limited to 'app-misc/fujiplay')
-rw-r--r--app-misc/fujiplay/Manifest1
-rw-r--r--app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch4
-rw-r--r--app-misc/fujiplay/fujiplay-1.33-r1.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/fujiplay/Manifest b/app-misc/fujiplay/Manifest
index cf4af29ecfe5..ef977f241d8a 100644
--- a/app-misc/fujiplay/Manifest
+++ b/app-misc/fujiplay/Manifest
@@ -1 +1,2 @@
+DIST fujiplay-1.33.tar.gz 12588 BLAKE2B 4be2b4d44696f5d43942c19cde308874684c87762b2778026750c4db9ba249c2ec8b7986bca5c526c7199289b3094157c068067db38a015372fd6fbd5a1e285d SHA512 168ce95b6926da2438fb858b2537060877145b28638217214f72833fcc75b76dd7e5bba9ed0ca966cd2f7f1c31ca3302ee4662907bf743c393314d615d795149
DIST fujiplay.tgz 12588 BLAKE2B 4be2b4d44696f5d43942c19cde308874684c87762b2778026750c4db9ba249c2ec8b7986bca5c526c7199289b3094157c068067db38a015372fd6fbd5a1e285d SHA512 168ce95b6926da2438fb858b2537060877145b28638217214f72833fcc75b76dd7e5bba9ed0ca966cd2f7f1c31ca3302ee4662907bf743c393314d615d795149
diff --git a/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch b/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch
index 7f03c696c20e..1ae946336242 100644
--- a/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch
+++ b/app-misc/fujiplay/files/fujiplay-1.33-unterminated-strings.patch
@@ -1,5 +1,5 @@
---- fujiplay.c 1999-02-23 10:30:31.000000000 +0100
-+++ fujiplay.c 2006-08-05 00:50:08.000000000 +0200
+--- a/fujiplay.c 1999-02-23 10:30:31.000000000 +0100
++++ b/fujiplay.c 2006-08-05 00:50:08.000000000 +0200
@@ -759,40 +759,38 @@
return 1;
}
diff --git a/app-misc/fujiplay/fujiplay-1.33-r1.ebuild b/app-misc/fujiplay/fujiplay-1.33-r1.ebuild
new file mode 100644
index 000000000000..796eccb8d312
--- /dev/null
+++ b/app-misc/fujiplay/fujiplay-1.33-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for Fujifilm/Leica digital cameras (via serial port)"
+HOMEPAGE="https://www.math.u-psud.fr/~bousch/fujiplay.html"
+SRC_URI="https://www.math.u-psud.fr/~bousch/${PN}.tgz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}"/${P}-unterminated-strings.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin fujiplay yycc2ppm
+ dodoc README fujiplay.lsm mx700-commands.html
+ emake all clean
+}
+
+pkg_postinst() {
+ ln -s /dev/ttyS0 /dev/fujifilm || die
+ elog "A symbolic link /dev/ttyS0 -> /dev/fujifilm was created."
+ elog "You may want to create a serial group to allow non-root"
+ elog "members R/W access to the serial device."
+ elog
+}
+
+pkg_postrm() {
+ rm -f /dev/fujifilm || die
+ elog
+ elog "The symbolic link /dev/fujifilm was removed."
+ elog
+}