summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-04-18 14:56:29 +0200
committerSam James <sam@gentoo.org>2023-04-18 14:28:02 +0100
commit1de89049f3dda69b47abc6a1aaee46dfbc2c5028 (patch)
tree5c6c3ba4c879fed5495a980bf1ab6067f33a3636 /app-misc
parentnet-libs/ignition-msgs: bump to 5.11.0 (diff)
downloadgentoo-1de89049f3dda69b47abc6a1aaee46dfbc2c5028.tar.gz
gentoo-1de89049f3dda69b47abc6a1aaee46dfbc2c5028.tar.bz2
gentoo-1de89049f3dda69b47abc6a1aaee46dfbc2c5028.zip
app-misc/g810-led: Fix for GCC 13
Closes: https://bugs.gentoo.org/895426 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/30640 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/g810-led/files/g810-led-0.4.2_gcc13.patch21
-rw-r--r--app-misc/g810-led/g810-led-0.4.2.ebuild6
2 files changed, 26 insertions, 1 deletions
diff --git a/app-misc/g810-led/files/g810-led-0.4.2_gcc13.patch b/app-misc/g810-led/files/g810-led-0.4.2_gcc13.patch
new file mode 100644
index 000000000000..041f000aef1f
--- /dev/null
+++ b/app-misc/g810-led/files/g810-led-0.4.2_gcc13.patch
@@ -0,0 +1,21 @@
+From 0ca17e2ba8c8f01e51a360903a2009186ff78a1c Mon Sep 17 00:00:00 2001
+From: Olav Reinert <seroton10@gmail.com>
+Date: Sun, 26 Mar 2023 13:48:10 +0200
+Subject: [PATCH] fix: compilation error with GCC 13
+
+---
+ src/helpers/help.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/helpers/help.h b/src/helpers/help.h
+index 1d176f0..b7d02fd 100644
+--- a/src/helpers/help.h
++++ b/src/helpers/help.h
+@@ -18,6 +18,7 @@
+ #define HELP_HELPER
+
+ #include <iostream>
++#include <cstdint>
+
+ namespace help {
+
diff --git a/app-misc/g810-led/g810-led-0.4.2.ebuild b/app-misc/g810-led/g810-led-0.4.2.ebuild
index 5b912b7836b9..b99c5dd3daea 100644
--- a/app-misc/g810-led/g810-led-0.4.2.ebuild
+++ b/app-misc/g810-led/g810-led-0.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2018-2021 Gentoo Authors
+# Copyright 2018-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,10 @@ DEPEND="${RDEPEND}"
DOCS=("README.md" "sample_profiles" "sample_effects")
+# Fix for GCC 13; Bug #895426
+# See https://github.com/MatMoul/g810-led/pull/302
+PATCHES=( "${FILESDIR}/g810-led-0.4.2_gcc13.patch" )
+
src_prepare() {
default
# See