summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-05-14 23:47:56 +0200
committerSam James <sam@gentoo.org>2022-05-15 00:11:50 +0000
commitbc68b44b53dd9e5142e62325d0a948489282044f (patch)
treec635cb666c16fe7b9d0df01f426a567f7c41d317 /app-misc
parentnet-libs/pacparser: fix copyright (diff)
downloadgentoo-bc68b44b53dd9e5142e62325d0a948489282044f.tar.gz
gentoo-bc68b44b53dd9e5142e62325d0a948489282044f.tar.bz2
gentoo-bc68b44b53dd9e5142e62325d0a948489282044f.zip
app-misc/astrolog: add 7.40
Closes: https://bugs.gentoo.org/750398 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/astrolog/Manifest1
-rw-r--r--app-misc/astrolog/astrolog-7.40.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
index 7850cd98bd9a..38a8d0dafb89 100644
--- a/app-misc/astrolog/Manifest
+++ b/app-misc/astrolog/Manifest
@@ -1 +1,2 @@
DIST ast54unx.shr 1465432 BLAKE2B 9eec58fb66110a7fd072eee8b02dda109a22c1a1d59506943011041ab595e33eac39f5372ab55f587bcdfb447e599b16b8a9f0ccd04c54257b0dd38a85acde08 SHA512 824fcea1891dafc77692e84a36cc97a8afd90ad93d772edab8437e89869cdc912002f628fd86eecc8182ba4f1ad02cb98f42a30fde425bf94cf59f852b4eda1a
+DIST ast74src.zip 4483648 BLAKE2B d15d3e5d98337c5c5884973d079cffda9144a5c9f43ab48dd38f782eeef089d9fd5fb3f5a01f1d607bd2134e6a774494d4cf7d99e117d3092c8787626436e778 SHA512 540bda7ee10cde0723f6bd4afe410e4e9c59168e31dbdbd0b3b62a9e77ae83a971543fc812876258e2b7b9636f880c74b9be5497c54e7dd0e9b444bad2edbf6b
diff --git a/app-misc/astrolog/astrolog-7.40.ebuild b/app-misc/astrolog/astrolog-7.40.ebuild
new file mode 100644
index 000000000000..9c3aa7f25720
--- /dev/null
+++ b/app-misc/astrolog/astrolog-7.40.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="http://www.astrolog.org/astrolog.htm"
+SRC_URI="http://www.astrolog.org/ftp/ast74src.zip"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile || die
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h || die
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h || die)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc astrolog.doc changes.doc
+ insinto /usr/share/astrolog
+ doins astrolog.as
+}
+
+pkg_postinst() {
+ elog "There is a sample config file /usr/share/astrolog/astrolog.as"
+ elog "astrolog looks in current dir for a file astrolog.as before"
+ elog "using the file in /usr/share/astrolog"
+ elog "If you want extended accuracy of astrolog's calculations you"
+ elog "can emerge the optional package \"astrolog-ephemeris\" which"
+ elog "needs ~32.9 MB additional diskspace for the ephemeris-files"
+}