summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 00:26:34 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 00:27:44 +0100
commitf032ecb63158bac3a62c1467825f45a80764118f (patch)
tree53b48a20ea2ebf08982a588a170cd2113fa98818 /app-mobilephone
parentdev-lang/python: depend on app-arch/xz-utils[extra-filters] for tests (diff)
downloadgentoo-f032ecb63158bac3a62c1467825f45a80764118f.tar.gz
gentoo-f032ecb63158bac3a62c1467825f45a80764118f.tar.bz2
gentoo-f032ecb63158bac3a62c1467825f45a80764118f.zip
app-mobilephone/wammu: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/wammu-0.40.ebuild19
-rw-r--r--app-mobilephone/wammu/wammu-0.43.ebuild19
2 files changed, 8 insertions, 30 deletions
diff --git a/app-mobilephone/wammu/wammu-0.40.ebuild b/app-mobilephone/wammu/wammu-0.40.ebuild
index 9b7861ba00af..320c41fab713 100644
--- a/app-mobilephone/wammu/wammu-0.40.ebuild
+++ b/app-mobilephone/wammu/wammu-0.40.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,29 +25,18 @@ RDEPEND="|| ( ( >=app-mobilephone/gammu-1.36 dev-python/python-gammu )
DEPEND="${RDEPEND}"
# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
# Required to source locale content out of the box
DISTUTILS_IN_SOURCE_BUILD=1
src_prepare() {
- local lang support_linguas=no
+ local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
+ if ! has ${lang} ${LINGUAS-${lang}} ; then
+ rm -r locale/${lang} || die
fi
done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -r locale/${lang} || die
- fi
- done
- fi
distutils-r1_src_prepare
}
diff --git a/app-mobilephone/wammu/wammu-0.43.ebuild b/app-mobilephone/wammu/wammu-0.43.ebuild
index d13beae0c763..dd959761aaee 100644
--- a/app-mobilephone/wammu/wammu-0.43.ebuild
+++ b/app-mobilephone/wammu/wammu-0.43.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,29 +27,18 @@ RDEPEND="
DEPEND="${RDEPEND}"
# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
# Required to source locale content out of the box
DISTUTILS_IN_SOURCE_BUILD=1
src_prepare() {
- local lang support_linguas=no
+ local lang
for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- support_linguas=yes
- break
+ if ! has ${lang} ${LINGUAS-${lang}} ; then
+ rm -r locale/${lang} || die
fi
done
- # install all languages when all selected LINGUAS aren't supported
- if [ "${support_linguas}" = "yes" ]; then
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if ! use linguas_${lang} ; then
- rm -r locale/${lang} || die
- fi
- done
- fi
distutils-r1_src_prepare
}