summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-01 20:29:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-01 20:33:33 +0100
commit1c13f9d58fe55ae5d0f699a62bdc1c76cbf1a95a (patch)
treedb005d48a9e3dbf1a0a965a6bd16d1c36734abef /app-portage
parentnet-misc/dropbear: Stabilize 2022.83 amd64, #898612 (diff)
downloadgentoo-1c13f9d58fe55ae5d0f699a62bdc1c76cbf1a95a.tar.gz
gentoo-1c13f9d58fe55ae5d0f699a62bdc1c76cbf1a95a.tar.bz2
gentoo-1c13f9d58fe55ae5d0f699a62bdc1c76cbf1a95a.zip
app-portage/gemato: Bump to 20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-20.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 3832b2dd2e30..372229f03bc7 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-19.0.gh.tar.gz 86174 BLAKE2B b13e17f3b4388df4c0b6980db8347d68f9e6cb2657cdbcb28a8466bcdebed9e986ecac2f0f88e549741eb62accd91ed48a8ee4a714a5decce68e1529174a4c90 SHA512 3a8dfc94770e4063da8f1bf42ffc4c261345af89edd223bbf64033a82c2e31cb3369b98467fdbe9bf911b76e5ef964b676b94803579525697ddc31be1b83017b
+DIST gemato-20.0.gh.tar.gz 86296 BLAKE2B 663a479650fa6b7a989882c9233ba1cf11b5a528ef4ccc14aed2c32c7a52d877fd1efe9af29c5ed61ee0f8c846e89a52547a2cb6d0256ede5816527defe876ef SHA512 e8b3c515e7dcf32b34101d644ba658b3c534b117407f3b65543dfb684f9569969468c6a5d0290e698d204de6c4a2a18baf722c8e7a6d24d079319310e82e6803
diff --git a/app-portage/gemato/gemato-20.0.ebuild b/app-portage/gemato/gemato-20.0.ebuild
new file mode 100644
index 000000000000..7e02cc9bba9d
--- /dev/null
+++ b/app-portage/gemato/gemato-20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+SRC_URI="
+ https://github.com/projg2/gemato/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}