summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-01-10 06:27:27 +0900
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-11 17:47:12 +0000
commit90660acc63a622dc6aba16646f2a69e4c8ee61c2 (patch)
tree92846666fb6e2ab2c6e72bab251425c35815ef65 /dev-cpp
parentdev-cpp/benchmark: Add patch to fix build failure on gcc-11 (diff)
downloadgentoo-90660acc63a622dc6aba16646f2a69e4c8ee61c2.tar.gz
gentoo-90660acc63a622dc6aba16646f2a69e4c8ee61c2.tar.bz2
gentoo-90660acc63a622dc6aba16646f2a69e4c8ee61c2.zip
dev-cpp/benchmark: Add support for debug USE flag
Closes: https://bugs.gentoo.org/764653 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19011 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.2.ebuild b/dev-cpp/benchmark/benchmark-1.5.2.ebuild
index e3a3e8cfb6eb..840648c7edc2 100644
--- a/dev-cpp/benchmark/benchmark-1.5.2.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.5.2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="test"
+IUSE="debug test"
RESTRICT="!test? ( test )"
PATCHES=(
@@ -26,5 +26,7 @@ src_configure() {
-DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
)
+ use debug || append-cppflags -DNDEBUG
+
cmake_src_configure
}