summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/gnome-keyring-sharp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/gnome-keyring-sharp')
-rw-r--r--dev-dotnet/gnome-keyring-sharp/Manifest1
-rw-r--r--dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch10
-rw-r--r--dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild44
-rw-r--r--dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2.ebuild44
-rw-r--r--dev-dotnet/gnome-keyring-sharp/metadata.xml8
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-dotnet/gnome-keyring-sharp/Manifest b/dev-dotnet/gnome-keyring-sharp/Manifest
new file mode 100644
index 000000000000..30801288754e
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/Manifest
@@ -0,0 +1 @@
+DIST gnome-keyring-sharp-1.0.2.tar.gz 308244 SHA256 043e3e22132bdfe34e8ca314b6fd34bb0bc55a23eeb102778c64c243bb595315 SHA512 aad2fc1515a9d94971326a626d5957772927af5472afdbb517192e57c3928f32705c284b9599f350384a0c5d9cd7665b46677d550efe8506e27b485e2c40dcf0 WHIRLPOOL 2ce743dda131a15e1c6c46537322f8040b813bb91474f8bdabdb2d3006a2dd2467167fe790d10e027980fd20c46a14b8bdd27d6c7ad425b27247121001682dee
diff --git a/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
new file mode 100644
index 000000000000..71945c236635
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/files/gnome-keyring-sharp-1.0.2-monodoc-dir.patch
@@ -0,0 +1,10 @@
+diff -uNr gnome-keyring-sharp-1.0.1.old/docs/Makefile.am gnome-keyring-sharp-1.0.1/docs/Makefile.am
+--- gnome-keyring-sharp-1.0.1.old/docs/Makefile.am 2009-05-07 17:32:19.000000000 +0200
++++ gnome-keyring-sharp-1.0.1/docs/Makefile.am 2011-10-31 17:03:46.648191581 +0100
+@@ -1,5 +1,5 @@
+ if ENABLE_MONODOC
+-SOURCESDIR=$(libdir)/monodoc/sources
++SOURCESDIR=$(prefix)/lib/monodoc/sources
+ TARGETS=Gnome.Keyring.tree Gnome.Keyring.zip Gnome.Keyring.source
+ UPDATER = $(MONODOCER) -path:Gnome.Keyring $(UPDATE_ASSEMBLIES)
+ else
diff --git a/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..d0dc0a6f03c3
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils mono-env
+
+DESCRIPTION="C# implementation of gnome-keyring"
+HOMEPAGE="http://www.mono-project.com/ https://github.com/mono/gnome-keyring-sharp"
+SRC_URI="http://www.go-mono.com/archive/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/mono-2.0
+ >=gnome-base/libgnome-keyring-2.30.0
+ dev-dotnet/glib-sharp
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable building samples.
+ sed -i -e 's:sample::' "${S}"/Makefile.in || die "sed failed"
+
+ # Apply Fedora patches
+ epatch "${FILESDIR}/${PN}-1.0.2-monodoc-dir.patch"
+ eautoreconf
+}
+
+src_compile() {
+ # This dies without telling in docs with anything not -j1
+ # CSC=gmcs needed for http://bugs.gentoo.org/show_bug.cgi?id=250069
+ emake -j1 CSC=gmcs
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2.ebuild b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2.ebuild
new file mode 100644
index 000000000000..45927c6049ce
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/gnome-keyring-sharp-1.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit mono
+
+DESCRIPTION="C# implementation of gnome-keyring"
+HOMEPAGE="http://www.mono-project.com/ https://github.com/mono/gnome-keyring-sharp"
+SRC_URI="http://www.go-mono.com/archive/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=gnome-base/libgnome-keyring-2.30.0
+ dev-dotnet/glib-sharp"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Disable building samples.
+ sed -i -e 's:sample::' "${S}"/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf $(use_enable doc monodoc) || die "econf failed"
+}
+
+src_compile() {
+ # This dies without telling in docs with anything not -j1
+ # CSC=gmcs needed for http://bugs.gentoo.org/show_bug.cgi?id=250069
+ emake -j1 CSC=gmcs || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die
+ mono_multilib_comply
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
diff --git a/dev-dotnet/gnome-keyring-sharp/metadata.xml b/dev-dotnet/gnome-keyring-sharp/metadata.xml
new file mode 100644
index 000000000000..7bc9c3374745
--- /dev/null
+++ b/dev-dotnet/gnome-keyring-sharp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <upstream>
+ <remote-id type="github">mono/gnome-keyring-sharp</remote-id>
+ </upstream>
+</pkgmetadata>