summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-15 21:31:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 22:32:59 +0000
commit0fecc1bb27f43bec03373c08c8ad205956c4b995 (patch)
treec973b8a17fd68e599388ce3329bf0f94bd70cee7 /dev-haskell
parentdev-haskell/ekg-core: bump up to 0.1.1.7 (diff)
downloadgentoo-0fecc1bb27f43bec03373c08c8ad205956c4b995.tar.gz
gentoo-0fecc1bb27f43bec03373c08c8ad205956c4b995.tar.bz2
gentoo-0fecc1bb27f43bec03373c08c8ad205956c4b995.zip
dev-haskell/hoauth2: bump up to 1.16.0
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hoauth2/Manifest1
-rw-r--r--dev-haskell/hoauth2/hoauth2-1.16.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/Manifest b/dev-haskell/hoauth2/Manifest
index 53cf80a49e43..9af62005808d 100644
--- a/dev-haskell/hoauth2/Manifest
+++ b/dev-haskell/hoauth2/Manifest
@@ -1 +1,2 @@
DIST hoauth2-1.11.0.tar.gz 18270 BLAKE2B 8258e8e7a1bfe12ca0da09297c18354617cb525aee70418a85a56cd5421b4695aa22861e1368fbd2d0ac11ff155fd4cebb8d220ebc4b1f7c3403268682e11e95 SHA512 179c97045f33da6f6cb4c153b9be3482031ce8a150ad70defcbbbfa3c67ff10b31c86c45d845aa605b9c4d3ac921f4372bcd49fbb384e0c78409219bc0bf1607
+DIST hoauth2-1.16.0.tar.gz 18479 BLAKE2B ca9aa0d35d3bfb9ee3a9cbe62c2ecb1a0efd109c89600642a062fbcbe62cefae53f4810b38eb55b81c29c72e4b80aca8f746966ccbaf17ecc83883e2f6fc3528 SHA512 fe42759c2ccaf035bfa15d9276a7c8bf6608a7b74732c6950c2081616196296a73c34474989c1eda5fcfc15066626e1facf2f58b6977d5e00520290948731cb6
diff --git a/dev-haskell/hoauth2/hoauth2-1.16.0.ebuild b/dev-haskell/hoauth2/hoauth2-1.16.0.ebuild
new file mode 100644
index 000000000000..ebe4fd23f0ae
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-1.16.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication client"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.3.0.0:=[profile?] <dev-haskell/aeson-1.6:=[profile?]
+ >=dev-haskell/binary-0.8.3:=[profile?]
+ >=dev-haskell/exceptions-0.8.3:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.11:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/microlens-0.4.0:=[profile?] <dev-haskell/microlens-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?]
+ >=dev-haskell/uri-bytestring-0.2.3.1:=[profile?] <dev-haskell/uri-bytestring-0.4:=[profile?]
+ >=dev-haskell/uri-bytestring-aeson-0.1:=[profile?] <dev-haskell/uri-bytestring-aeson-0.2:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}