summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-09-13 07:17:25 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-09-18 14:11:36 +0200
commit200e04953887f8630e24ee34cc88e79a682be1b8 (patch)
tree1456a09a8c896c30f915b580795b70eba1f96f2a /dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild
parentdev-java/checker-framework-qual: add 3.47.0 (diff)
downloadgentoo-200e04953887f8630e24ee34cc88e79a682be1b8.tar.gz
gentoo-200e04953887f8630e24ee34cc88e79a682be1b8.tar.bz2
gentoo-200e04953887f8630e24ee34cc88e79a682be1b8.zip
dev-java/error-prone-annotations: add 2.32.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/38605/commits/95293822fd9a971a298865e3327112790f98fabf Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild')
-rw-r--r--dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild b/dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild
new file mode 100644
index 000000000000..4f6b1d2395ad
--- /dev/null
+++ b/dev-java/error-prone-annotations/error-prone-annotations-2.32.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.google.errorprone:error_prone_annotations:${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java annotations for the Error Prone static analysis tool"
+HOMEPAGE="https://errorprone.info"
+SRC_URI="https://github.com/google/error-prone/archive/v${PV}.tar.gz -> error-prone-${PV}.tar.gz"
+S="${WORKDIR}/error-prone-${PV}/annotations"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-11:*" # module-info
+RDEPEND=">=virtual/jre-1.8:*"
+
+JAVA_SRC_DIR="src/main/java"