summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/felix-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/felix-utils')
-rw-r--r--dev-java/felix-utils/Manifest1
-rw-r--r--dev-java/felix-utils/felix-utils-1.2.0.ebuild46
-rw-r--r--dev-java/felix-utils/files/felix-utils-1.2.0-build.xml299
-rw-r--r--dev-java/felix-utils/files/felix-utils-1.2.0-java-fixes.patch47
-rw-r--r--dev-java/felix-utils/metadata.xml5
5 files changed, 398 insertions, 0 deletions
diff --git a/dev-java/felix-utils/Manifest b/dev-java/felix-utils/Manifest
new file mode 100644
index 000000000000..74c8f4161afc
--- /dev/null
+++ b/dev-java/felix-utils/Manifest
@@ -0,0 +1 @@
+DIST org.apache.felix.utils-1.2.0-source-release.tar.gz 36109 SHA256 281872667d5968875f5f5b12878145c7f184ffb89d3ddf8ad757070e0722105c SHA512 4b3a16abc92963c16c363791423483c14eb02792cc65d58a884777c6be25b05a226492280cf2f77183ad5b86cb5710076a118a58af34f6c717273bfdf93bc171 WHIRLPOOL a9422c4fda79d1ba32cfff923d911a4e91fab463c8de0b870f43daf683222f86963690834df1d37a67f3cba4849a1f85433f7239abd100abfa1c6ef3a1d6b91c
diff --git a/dev-java/felix-utils/felix-utils-1.2.0.ebuild b/dev-java/felix-utils/felix-utils-1.2.0.ebuild
new file mode 100644
index 000000000000..235bf21e41f3
--- /dev/null
+++ b/dev-java/felix-utils/felix-utils-1.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="Felix Utils"
+HOMEPAGE="http://felix.apache.org/"
+LICENSE="Apache-2.0"
+
+MY_PN="org.apache.felix.utils"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://apache/felix/${MY_P}-source-release.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/felix-gogo-runtime:0
+ dev-java/osgi-compendium:0
+ dev-java/osgi-core-api:0"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ epatch "${FILESDIR}"/${P}-java-fixes.patch
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only osgi-core-api osgi-core-api.jar):$(java-pkg_getjar --build-only osgi-compendium osgi-compendium.jar):$(java-pkg_getjar --build-only felix-gogo-runtime felix-gogo-runtime.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mv "${S}"/target/{${MY_P},${PN}}.jar || die
+
+ java-osgi_dojar "${S}"/target/${PN}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+}
diff --git a/dev-java/felix-utils/files/felix-utils-1.2.0-build.xml b/dev-java/felix-utils/files/felix-utils-1.2.0-build.xml
new file mode 100644
index 000000000000..cfe95ef2c6cf
--- /dev/null
+++ b/dev-java/felix-utils/files/felix-utils-1.2.0-build.xml
@@ -0,0 +1,299 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/13/13 2:09 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="org.apache.felix.utils-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="org.apache.felix.utils-1.2.0"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="jsr14"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="changelog.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="jsr14"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0"/>
+ <get src="http://repository.apache.org/snapshots/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/osgi/org.osgi.compendium/4.1.0"/>
+ <get src="http://repository.apache.org/snapshots/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.compendium/4.1.0/org.osgi.compendium-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.0"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.0/junit-4.0.jar"
+ dest="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.0/junit-4.0.jar"
+ dest="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/easymock/easymock/2.4"/>
+ <get src="http://repository.apache.org/snapshots/org/easymock/easymock/2.4/easymock-2.4.jar"
+ dest="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/easymock/easymock/2.4/easymock-2.4.jar"
+ dest="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/mockito/mockito-all/1.7"/>
+ <get src="http://repository.apache.org/snapshots/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/felix-utils/files/felix-utils-1.2.0-java-fixes.patch b/dev-java/felix-utils/files/felix-utils-1.2.0-java-fixes.patch
new file mode 100644
index 000000000000..a973ca56a862
--- /dev/null
+++ b/dev-java/felix-utils/files/felix-utils-1.2.0-java-fixes.patch
@@ -0,0 +1,47 @@
+--- a/src/main/java/org/apache/felix/utils/filter/FilterImpl.java 2012-06-12 08:56:50.000000000 +0200
++++ b/src/main/java/org/apache/felix/utils/filter/FilterImpl.java 2013-05-13 14:25:58.601527069 +0200
+@@ -25,6 +25,7 @@
+ import java.security.AccessController;
+ import java.security.PrivilegedAction;
+ import java.util.*;
++import java.util.Map.Entry;
+
+ import org.apache.felix.utils.version.VersionTable;
+ import org.osgi.framework.Filter;
+@@ -111,6 +111,19 @@
+ converted = conv;
+ }
+
++ @Override
++ public boolean matches(Map<String, ?> map)
++ {
++ Map nonGenericMap = new HashMap();
++
++ for(Entry<String, ?> entry : map.entrySet())
++ {
++ nonGenericMap.put(entry.getKey(), entry.getValue());
++ }
++
++ return match0(nonGenericMap);
++ }
++
+
+ /**
+ * Filter using a service's properties.
+@@ -575,13 +587,13 @@
+ switch (operation) {
+ case APPROX :
+ case EQUAL : {
+- return ((Version) value1).compareTo(converted) == 0;
++ return ((Version) value1).compareTo((Version) converted) == 0;
+ }
+ case GREATER: {
+- return ((Version) value1).compareTo(converted) >= 0;
++ return ((Version) value1).compareTo((Version) converted) >= 0;
+ }
+ case LESS: {
+- return ((Version) value1).compareTo(converted) <= 0;
++ return ((Version) value1).compareTo((Version) converted) <= 0;
+ }
+ }
+ } else {
diff --git a/dev-java/felix-utils/metadata.xml b/dev-java/felix-utils/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/felix-utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>