summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-17 08:29:11 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-17 08:29:20 +0100
commita6b90c93b8cc5539bf35db34fe472c72c7175fc1 (patch)
tree94d15d6d896957facceeaf548a6ecedaca94d6ec /dev-lang/elixir
parentnet-analyzer/zabbix: bump to 4.0.21 (diff)
downloadgentoo-a6b90c93b8cc5539bf35db34fe472c72c7175fc1.tar.gz
gentoo-a6b90c93b8cc5539bf35db34fe472c72c7175fc1.tar.bz2
gentoo-a6b90c93b8cc5539bf35db34fe472c72c7175fc1.zip
dev-lang/elixir: take src_test and src_install more verbose
Print exact command to eare rerunning subset of test suite. Bug: https://bugs.gentoo.org/727344 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/elixir')
-rw-r--r--dev-lang/elixir/elixir-1.10.3.ebuild5
-rw-r--r--dev-lang/elixir/files/elixir-1.10.3-no-Q.patch12
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-lang/elixir/elixir-1.10.3.ebuild b/dev-lang/elixir/elixir-1.10.3.ebuild
index 12dc7c530fe1..47f8a8ca0780 100644
--- a/dev-lang/elixir/elixir-1.10.3.ebuild
+++ b/dev-lang/elixir/elixir-1.10.3.ebuild
@@ -27,12 +27,9 @@ DEPEND+="
PATCHES=(
"${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
)
-src_compile() {
- emake Q=""
-}
-
src_install() {
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
diff --git a/dev-lang/elixir/files/elixir-1.10.3-no-Q.patch b/dev-lang/elixir/files/elixir-1.10.3-no-Q.patch
new file mode 100644
index 000000000000..3f55785839b7
--- /dev/null
+++ b/dev-lang/elixir/files/elixir-1.10.3-no-Q.patch
@@ -0,0 +1,12 @@
+Enable verbose builds by default.
+--- a/Makefile
++++ b/Makefile
+@@ -8,7 +8,7 @@ ERLC := erlc -I lib/elixir/include $(ERLC_OPTS)
+ ERL := erl -I lib/elixir/include -noshell -pa lib/elixir/ebin
+ GENERATE_APP := $(CURDIR)/lib/elixir/generate_app.escript
+ VERSION := $(strip $(shell cat VERSION))
+-Q := @
++Q :=
+ LIBDIR := lib
+ BINDIR := bin
+ INSTALL = install