summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-10 17:34:20 -0400
committerSam James <sam@gentoo.org>2024-03-11 14:22:44 +0000
commitd1756d21b4d9fe56cc77c031a4d28e9dd79a854b (patch)
tree9bdbe53dc23b86c042e3ac3c956a4bdf1618c623 /dev-lang/f2c
parentdev-libs/libf2c: add 20240130 (diff)
downloadgentoo-d1756d21b4d9fe56cc77c031a4d28e9dd79a854b.tar.gz
gentoo-d1756d21b4d9fe56cc77c031a4d28e9dd79a854b.tar.bz2
gentoo-d1756d21b4d9fe56cc77c031a4d28e9dd79a854b.zip
dev-lang/f2c: add 20240130
Stop downloading the sources from Debian. Gentoo has a perfectly good mirror network too. And Debian only packages ancient versions. We don't really need their patches either. If upstream wants a manpage, upstream will include one Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/f2c')
-rw-r--r--dev-lang/f2c/Manifest1
-rw-r--r--dev-lang/f2c/f2c-20240130.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-lang/f2c/Manifest b/dev-lang/f2c/Manifest
index 0c71c3a35293..5101abe660f2 100644
--- a/dev-lang/f2c/Manifest
+++ b/dev-lang/f2c/Manifest
@@ -1,2 +1,3 @@
+DIST f2c-20240130.tar.gz 285158 BLAKE2B 525f53b12f3ab8c7dd5d4156dd03569b0923df3a5af04fc56965edb18932808434944b8b99fa8c1541ff3e9d6b413441f4dd55d921b63964f8906872f1674231 SHA512 dfa702a6f05139557e1f8f6d8dd9f4b54a5b277094f5202a8f9acf83f4043a9dfae3455bbac4f5c86f6027ffbe36b334b2bc085f85d3ced43634d6face9fec45
DIST f2c_20100827-1.debian.tar.gz 15659 BLAKE2B 4773a939e51074df34b48540ed67d0bd3dce85b64d6118c480217b569bbe11a9907a7a8bf2d68f0ec5fae51c65ec29a9dafdac1a009a90b5c6d02306496a72d5 SHA512 784d3f1a74311a933b54103d36dd18eb879bef1816ea82e8d93ef5a0eb7582d4ddde3a2b764d15b78194bab4cdf940480089e8b920002134af66cdf095708535
DIST f2c_20100827.orig.tar.gz 417930 BLAKE2B 4ccd59762947de9d316520f213d33e095a559dfe914c06d58f4db21a031b6dca332d75473dbaa6a6167ef3f0459c68235fdddac3ed4dcea34e9597a8ab0ae982 SHA512 2c28d8c06e53b569816e7982725133d46e9b145a84ec51771f4cca2409098f894648ebe5b8089a1ddd8468be62394b0edb5985e50baeea8129e4f507236d6c0d
diff --git a/dev-lang/f2c/f2c-20240130.ebuild b/dev-lang/f2c/f2c-20240130.ebuild
new file mode 100644
index 000000000000..8ce0baf4d65a
--- /dev/null
+++ b/dev-lang/f2c/f2c-20240130.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Fortran to C converter"
+HOMEPAGE="https://www.netlib.org/f2c"
+SRC_URI="
+ https://www.netlib.org/f2c/src.tgz -> ${P}.tar.gz
+"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/libf2c-20130927-r1"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20100827-fix-buildsystem.patch
+)
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/855593
+ # Upstream bug reports are handled via email. I have sent one and
+ # will follow up by myself.
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ tc-export CC
+}
+
+src_compile() {
+ emake -C src -f makefile.u f2c
+}
+
+src_install() {
+ dobin src/f2c
+
+ dodoc src/README src/Notice
+
+}