summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-20 22:55:59 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-20 22:56:31 +0100
commitdacd3a7b9111a3a590da3ce4a4a04dff012e5790 (patch)
tree1d3d6ec58db76d7a1b99e366ee1b0546c1f29082 /dev-lang/gnucobol
parentapp-editors/emacs: Disable tests that use bwrap (diff)
downloadgentoo-dacd3a7b9111a3a590da3ce4a4a04dff012e5790.tar.gz
gentoo-dacd3a7b9111a3a590da3ce4a4a04dff012e5790.tar.bz2
gentoo-dacd3a7b9111a3a590da3ce4a4a04dff012e5790.zip
dev-lang/gnucobol: fix undefined symbol
Closes: https://bugs.gentoo.org/913558 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnucobol')
-rw-r--r--dev-lang/gnucobol/files/gnucobol-3.1.2-ncurses.patch20
-rw-r--r--dev-lang/gnucobol/gnucobol-3.1.2.ebuild7
2 files changed, 25 insertions, 2 deletions
diff --git a/dev-lang/gnucobol/files/gnucobol-3.1.2-ncurses.patch b/dev-lang/gnucobol/files/gnucobol-3.1.2-ncurses.patch
new file mode 100644
index 000000000000..b778f57764b1
--- /dev/null
+++ b/dev-lang/gnucobol/files/gnucobol-3.1.2-ncurses.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac 2023-12-20 22:48:44.764596449 +0100
++++ b/configure.ac 2023-12-20 22:50:10.493170634 +0100
+@@ -1109,7 +1109,7 @@
+ USE_CURSES="missing_header"
+ fi], [])], [])
+ if test "$USE_CURSES" = "ncursesw"; then
+- LIBCOB_LIBS="$LIBCOB_LIBS -lncursesw"
++ LIBCOB_LIBS="$LIBCOB_LIBS $(ncursesw6-config --libs)"
+ fi
+ else
+ if test "$USE_CURSES" = "ncursesw"; then
+@@ -1128,7 +1128,7 @@
+ USE_CURSES="missing_header"
+ fi], [])], [])], [])
+ if test "$USE_CURSES" = "ncurses"; then
+- LIBCOB_LIBS="$LIBCOB_LIBS -lncurses"
++ LIBCOB_LIBS="$LIBCOB_LIBS $(ncurses6-config --libs)"
+ fi
+ else
+ if test "$USE_CURSES" = "ncurses"; then
diff --git a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
index b6419a90cf82..bfd13e668871 100644
--- a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
+++ b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,10 @@ BDEPEND="sys-devel/libtool"
DOCS=( AUTHORS ChangeLog NEWS README README.md )
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ncurses.patch
+)
src_prepare() {
default