summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-01-19 07:32:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-01-19 07:32:11 +0000
commit057af034ac23b7d508919e79b3fb55d521b62d79 (patch)
treecb03d08bd0d12680b03fd11cc2118cac1ec43656 /dev-lang/ispc
parentwww-apps/grafana-bin: Bump (diff)
downloadgentoo-057af034ac23b7d508919e79b3fb55d521b62d79.tar.gz
gentoo-057af034ac23b7d508919e79b3fb55d521b62d79.tar.bz2
gentoo-057af034ac23b7d508919e79b3fb55d521b62d79.zip
dev-lang/ispc: Bump to 1.17.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest1
-rw-r--r--dev-lang/ispc/ispc-1.17.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index 59e44b09137a..a461c6e709b2 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,2 +1,3 @@
DIST ispc-1.16.0.tar.gz 19548153 BLAKE2B 9b6d9329430d59041a76c20332b527560afa47a5585652abdf93aedb7907483d1647c829f2bd3f396cd53301bc79367cd91606b90a543fa8bec2f6ab34452989 SHA512 8469db4e3e9834477345b431162543f1c8e680aa9834c9a50239781dc7febfdde0561c2f13d1387e37f95a18c4376a85cb9cbae33cb614dc8977dfc9f47da215
DIST ispc-1.16.1.tar.gz 19549428 BLAKE2B 742d94208d39f0560c3f2199ee06fc12f3ec2cf47c1039212219c6aa106b20cd58219e5d439c4fd1ce4a0c1a423655d0c2113a2a78152c99b4d77452171acce6 SHA512 89b844a15a888ae7074c4baa47f46d1d7176501f215c9a8c3b4bf9ad1960dc77d53f1f448d5253ad0c6a91e5088af243c3dfd148e619f9abeb6a16f715e3b463
+DIST ispc-1.17.0.tar.gz 19436681 BLAKE2B 11af6e22c4c297a2fbd0ae1bfe2a37ce2f836607b2caf42634cff0b0fe1116542e71f056de12e3472724db04f1c5174c0deb47c2bd64fb756b4bdaef48935707 SHA512 b1c67381bb8b71d268c6e68c95cc5e2d64411ce351506de96d31850b879f7777fbc1cb33f3761437f84e52ae726fabbb794ebba9cf05d5200acaca07a2ebf0ac
diff --git a/dev-lang/ispc/ispc-1.17.0.ebuild b/dev-lang/ispc/ispc-1.17.0.ebuild
new file mode 100644
index 000000000000..a0b5d2d84d28
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.17.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+LLVM_MAX_SLOT=12
+inherit cmake python-any-r1 llvm
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="https://ispc.github.io/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ispc/ispc.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="<sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-9999-llvm.patch"
+)
+
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if use amd64; then
+ # On amd64 systems, build system enables x86/i686 build too.
+ # This ebuild doesn't even have multilib support, nor need it.
+ # https://bugs.gentoo.org/730062
+ ewarn "Removing auto-x86 build on amd64"
+ sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DARM_ENABLED=$(usex arm)
+ -DCMAKE_SKIP_RPATH=ON
+ -DISPC_NO_DUMPS=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Inject path to prevent using system ispc
+ PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/bin/ispc
+ einstalldocs
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}