summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-14 10:11:19 +0100
committerSam James <sam@gentoo.org>2024-06-14 10:32:38 +0100
commitc9515336084e543b4661feb7d0e0568da7a79991 (patch)
tree94ee5c92c5183a1913ad669dd4e656a23ef1e449 /dev-lang/lazarus
parentdev-libs/libqt5pas: add 1.2.15 (diff)
downloadgentoo-c9515336084e543b4661feb7d0e0568da7a79991.tar.gz
gentoo-c9515336084e543b4661feb7d0e0568da7a79991.tar.bz2
gentoo-c9515336084e543b4661feb7d0e0568da7a79991.zip
dev-lang/lazarus: put back REQUIRED_USE
The change itself is right conceptually (see the USE=gui policy in QA guide), but Lazarus continues to be a mess and I've spent too much time on it for now. The right fix is to drop REQUIRED_USE (as we did) but also make *DEPEND reflect that. But given I don't really want to think about Lazarus again, I'm not going to do that right now. Its actual maintainer can do that. Bug: https://bugs.gentoo.org/934158 Closes: https://bugs.gentoo.org/934235 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/lazarus-3.0-r2.ebuild (renamed from dev-lang/lazarus/lazarus-3.0-r1.ebuild)7
-rw-r--r--dev-lang/lazarus/lazarus-3.4-r1.ebuild (renamed from dev-lang/lazarus/lazarus-3.4.ebuild)7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-lang/lazarus/lazarus-3.0-r1.ebuild b/dev-lang/lazarus/lazarus-3.0-r2.ebuild
index cd47f1f30556..464571a70783 100644
--- a/dev-lang/lazarus/lazarus-3.0-r1.ebuild
+++ b/dev-lang/lazarus/lazarus-3.0-r2.ebuild
@@ -18,8 +18,8 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
SLOT="0/3.0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
KEYWORDS="~amd64 ~x86"
-IUSE="+gui gtk2 gtk qt6 extras"
-REQUIRED_USE="extras? ( gui )"
+IUSE="+gui gtk2 gtk qt5 qt6 extras"
+REQUIRED_USE="gui? ( ^^ ( gtk2 gtk qt5 qt6 ) ) extras? ( gui )"
# Pascal ignores CFLAGS and does its own stripping. Nothing else can be done about it.
QA_FLAGS_IGNORED="
@@ -40,6 +40,7 @@ DEPEND="
gui? (
gtk2? ( x11-libs/gtk+:2 )
gtk? ( x11-libs/gtk+:3 )
+ qt5? ( dev-libs/libqt5pas:0/3.0 )
qt6? ( dev-libs/libqt6pas:0/3.0 )
)
"
@@ -70,6 +71,8 @@ src_compile() {
export LCL_PLATFORM=gtk2
elif ( use gtk ) ; then
export LCL_PLATFORM=gtk3
+ elif ( use qt5 ) ; then
+ export LCL_PLATFORM=qt5
else
export LCL_PLATFORM=qt6
fi
diff --git a/dev-lang/lazarus/lazarus-3.4.ebuild b/dev-lang/lazarus/lazarus-3.4-r1.ebuild
index cd47f1f30556..464571a70783 100644
--- a/dev-lang/lazarus/lazarus-3.4.ebuild
+++ b/dev-lang/lazarus/lazarus-3.4-r1.ebuild
@@ -18,8 +18,8 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
SLOT="0/3.0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
KEYWORDS="~amd64 ~x86"
-IUSE="+gui gtk2 gtk qt6 extras"
-REQUIRED_USE="extras? ( gui )"
+IUSE="+gui gtk2 gtk qt5 qt6 extras"
+REQUIRED_USE="gui? ( ^^ ( gtk2 gtk qt5 qt6 ) ) extras? ( gui )"
# Pascal ignores CFLAGS and does its own stripping. Nothing else can be done about it.
QA_FLAGS_IGNORED="
@@ -40,6 +40,7 @@ DEPEND="
gui? (
gtk2? ( x11-libs/gtk+:2 )
gtk? ( x11-libs/gtk+:3 )
+ qt5? ( dev-libs/libqt5pas:0/3.0 )
qt6? ( dev-libs/libqt6pas:0/3.0 )
)
"
@@ -70,6 +71,8 @@ src_compile() {
export LCL_PLATFORM=gtk2
elif ( use gtk ) ; then
export LCL_PLATFORM=gtk3
+ elif ( use qt5 ) ; then
+ export LCL_PLATFORM=qt5
else
export LCL_PLATFORM=qt6
fi