summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-29 11:26:41 -0400
committerSam James <sam@gentoo.org>2024-03-29 18:45:15 +0000
commit7a947b7e443647d8ab5aca6c0d05064fe519674c (patch)
tree37126272cf2133c38be671f5541671ebb42c95e9 /dev-lang/lua
parentsci-calculators/tiemu: mark as LTO-unsafe (diff)
downloadgentoo-7a947b7e443647d8ab5aca6c0d05064fe519674c.tar.gz
gentoo-7a947b7e443647d8ab5aca6c0d05064fe519674c.tar.bz2
gentoo-7a947b7e443647d8ab5aca6c0d05064fe519674c.zip
dev-lang/lua: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/lua-5.1.5-r200.ebuild5
-rw-r--r--dev-lang/lua/lua-5.3.6-r102.ebuild5
-rw-r--r--dev-lang/lua/lua-5.4.6.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-lang/lua/lua-5.1.5-r200.ebuild b/dev-lang/lua/lua-5.1.5-r200.ebuild
index 56b7cc7dbb99..7041b3869d45 100644
--- a/dev-lang/lua/lua-5.1.5-r200.ebuild
+++ b/dev-lang/lua/lua-5.1.5-r200.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit optfeature
+inherit libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -29,6 +29,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.1.4-test.patch
)
default
+ elibtoolize
}
src_configure() {
diff --git a/dev-lang/lua/lua-5.3.6-r102.ebuild b/dev-lang/lua/lua-5.3.6-r102.ebuild
index 723277fb487a..db6f23a4a9ac 100644
--- a/dev-lang/lua/lua-5.3.6-r102.ebuild
+++ b/dev-lang/lua/lua-5.3.6-r102.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic optfeature
+inherit flag-o-matic libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -24,6 +24,7 @@ BDEPEND="virtual/pkgconfig"
src_prepare() {
default
+ elibtoolize
if use elibc_musl; then
# locales on musl are non-functional (#834153)
diff --git a/dev-lang/lua/lua-5.4.6.ebuild b/dev-lang/lua/lua-5.4.6.ebuild
index b880a4d62f6b..9ec3e85313e3 100644
--- a/dev-lang/lua/lua-5.4.6.ebuild
+++ b/dev-lang/lua/lua-5.4.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic optfeature
+inherit flag-o-matic libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -29,6 +29,7 @@ PATCHES=(
src_prepare() {
default
+ elibtoolize
if use elibc_musl; then
# locales on musl are non-functional (#834153)