summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-05 08:02:22 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-05 08:21:32 +0000
commit4e89a4edbc73f13fd6c82aa0be01765579ddafd2 (patch)
tree8babd514a25f74f38b98c990352a9c57d285f8b3 /dev-lang/nasm
parentmedia-gfx/renderdoc: add 1.31 (diff)
downloadgentoo-4e89a4edbc73f13fd6c82aa0be01765579ddafd2.tar.gz
gentoo-4e89a4edbc73f13fd6c82aa0be01765579ddafd2.tar.bz2
gentoo-4e89a4edbc73f13fd6c82aa0be01765579ddafd2.zip
dev-lang/nasm: add 2.16.02
Closes: https://bugs.gentoo.org/916478 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/Manifest1
-rw-r--r--dev-lang/nasm/files/nasm-2.16.02-unconfig.patch11
-rw-r--r--dev-lang/nasm/nasm-2.16.02.ebuild73
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-lang/nasm/Manifest b/dev-lang/nasm/Manifest
index ddee0b50c4c7..48b66ce7fc14 100644
--- a/dev-lang/nasm/Manifest
+++ b/dev-lang/nasm/Manifest
@@ -1 +1,2 @@
DIST nasm-2.16.01.tar.xz 1017732 BLAKE2B 0f7e96648e3db6fa4a8e10a89885f61cab7d79af25adbcc9d4706b3af61206c3cae024b7f873d636f5c1b2cb34ce5e7fbecc16af9b59086e9a1f49fb37c59670 SHA512 51fccb5639ce019d9c423c0f279750ffbd74c64cd41dd3b185d1aa1a1aaed79c5d3cd8d4bebbc13ee249a375ed27457ea2abde1a4dbb24d354598fffd1254833
+DIST nasm-2.16.02.tar.xz 1044824 BLAKE2B daa3585e9aef3c388e3b577a52453b31aaa7f13942e621c21bbe6ec744ff30bf2692e853dda193b30006989cb10e40dcc1cf0107176e31fd5ee096baad28c7a1 SHA512 9ccafb4cd9064fb21f6551309d35ba7461de8da138b1239d76c2ea0c070a1a767f1019d5d705088375d625cfb73eebbfd9dfa3588107793b95354d89dcfd22c3
diff --git a/dev-lang/nasm/files/nasm-2.16.02-unconfig.patch b/dev-lang/nasm/files/nasm-2.16.02-unconfig.patch
new file mode 100644
index 000000000000..77478b7e68cc
--- /dev/null
+++ b/dev-lang/nasm/files/nasm-2.16.02-unconfig.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in 2024-04-05 07:51:48.394437050 -0000
++++ b/Makefile.in 2024-04-05 07:52:38.731388961 -0000
+@@ -214,7 +214,7 @@
+ INSDEP = x86/insns.dat x86/insns.pl x86/insns-iflags.ph x86/iflags.ph
+
+ config/unconfig.h: config/config.h.in
+- $(RUNPERL) $(tools)/unconfig.pl \
++ $(RUNPERL) $(top_srcdir)/autoconf/unconfig.pl \
+ '$(srcdir)' config/config.h.in config/unconfig.h
+
+ x86/iflag.c: $(INSDEP)
diff --git a/dev-lang/nasm/nasm-2.16.02.ebuild b/dev-lang/nasm/nasm-2.16.02.ebuild
new file mode 100644
index 000000000000..f1f5ac53b3bd
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.16.02.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ _BitScanReverse
+ _BitScanReverse64
+ __cpu_to_le16
+ __cpu_to_le32
+ __cpu_to_le64
+ _byteswap_uint64
+ _byteswap_ulong
+ _byteswap_ushort
+ cpu_to_le16
+ cpu_to_le32
+ cpu_to_le64
+ typeof
+)
+
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-code-pro
+ media-fonts/source-sans:3
+ virtual/perl-File-Spec
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+ "${FILESDIR}"/${PN}-2.16.02-unconfig.patch
+)
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/870214
+ # During the split of media-fonts/source-pro, the source-sans files
+ # were renamed. Currently depend on media-fonts/source-sans:3 which works
+ # with this sed.
+ sed -i 's/SourceSansPro/SourceSans3/g' doc/psfonts.ph || die
+
+ AT_M4DIR="${S}/autoconf/m4" eautoreconf
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install $(usex doc install_doc '')
+}