summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-07 09:47:14 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-07 10:40:02 +0000
commit84372036b2a637165ec9f7c21245c0374ca314c4 (patch)
tree672a290f84900d585af60f54185644dbd656eb43 /dev-lang/nasm
parentprofiles/features/musl: mask media-gfx/renderdoc (diff)
downloadgentoo-84372036b2a637165ec9f7c21245c0374ca314c4.tar.gz
gentoo-84372036b2a637165ec9f7c21245c0374ca314c4.tar.bz2
gentoo-84372036b2a637165ec9f7c21245c0374ca314c4.zip
dev-lang/nasm: skip implicit decl warning for musl
Closes: https://bugs.gentoo.org/928848 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/nasm-2.16.02.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.16.02.ebuild b/dev-lang/nasm/nasm-2.16.02.ebuild
index f1f5ac53b3bd..bd26dd550266 100644
--- a/dev-lang/nasm/nasm-2.16.02.ebuild
+++ b/dev-lang/nasm/nasm-2.16.02.ebuild
@@ -16,8 +16,11 @@ KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
QA_CONFIG_IMPL_DECL_SKIP=(
+ # Windows.
_BitScanReverse
_BitScanReverse64
+
+ # Linux headers that are not included.
__cpu_to_le16
__cpu_to_le32
__cpu_to_le64
@@ -27,7 +30,17 @@ QA_CONFIG_IMPL_DECL_SKIP=(
cpu_to_le16
cpu_to_le32
cpu_to_le64
+
+ # __typeof as gnu extensions are not enabled
typeof
+
+ # musl doesn't define __bswap_N in endian.h (it's named _bswapN
+ # instead). could be fixed to call this instead, or to include
+ # musl's byteswap.h instead, but it is much easier to fall back on
+ # __builtin_bswapN. Bug #928848
+ __bswap_16
+ __bswap_32
+ __bswap_64
)
# [fonts note] doc/psfonts.ph defines ordered list of font preference.