summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-24 19:06:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-24 19:10:50 +0200
commit4dfbeec29ef4a3f9cd41c91510affdb332ecb432 (patch)
tree4ca53ed44bce63016906777fbc964c7761f1434f /dev-lang/nim
parentdev-scheme/elk: dev-scheme/elk: Fix passing of incompatible pointer type (diff)
downloadgentoo-4dfbeec29ef4a3f9cd41c91510affdb332ecb432.tar.gz
gentoo-4dfbeec29ef4a3f9cd41c91510affdb332ecb432.tar.bz2
gentoo-4dfbeec29ef4a3f9cd41c91510affdb332ecb432.zip
dev-lang/nim: skip tests broken on CI
Closes: https://bugs.gentoo.org/930542 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/files/nim-2.0.4-testament-skipfile.txt80
-rw-r--r--dev-lang/nim/nim-2.0.4.ebuild2
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-lang/nim/files/nim-2.0.4-testament-skipfile.txt b/dev-lang/nim/files/nim-2.0.4-testament-skipfile.txt
new file mode 100644
index 000000000000..0e209464c4fb
--- /dev/null
+++ b/dev-lang/nim/files/nim-2.0.4-testament-skipfile.txt
@@ -0,0 +1,80 @@
+# -*- conf -*-
+# broken, bug https://bugs.gentoo.org/930542
+tests/c/temit.nim
+tests/ccgbugs/t10964.nim
+tests/niminaction/Chapter3/ChatApp/src/client.nim
+tests/niminaction/Chapter3/various3.nim
+tests/niminaction/Chapter6/WikipediaStats/concurrency.nim
+tests/niminaction/Chapter6/WikipediaStats/concurrency_regex.nim
+tests/niminaction/Chapter6/WikipediaStats/parallel_counts.nim
+tests/niminaction/Chapter8/sdl/sdl_test.nim
+tests/parallel/tdeepcopy.nim
+tests/parallel/tdeepcopy2.nim
+tests/parallel/tflowvar.nim
+tests/parallel/tlet_spawn.nim
+tests/parallel/tpi.nim
+tests/parallel/tsysspawn.nim
+tests/parallel/twaitany.nim
+tests/stdlib/thttpclient_ssl.nim
+tests/stdlib/tthreadpool.nim
+# broken
+tests/assert/tassert_c.nim
+tests/async/tasync_traceback.nim
+tests/coroutines/twait.nim
+tests/errmsgs/t14444.nim
+tests/errmsgs/tcall_with_default_arg.nim
+tests/errmsgs/tproper_stacktrace.nim
+tests/errmsgs/tproper_stacktrace2.nim
+tests/errmsgs/tproper_stacktrace3.nim
+tests/exception/t13115.nim
+tests/js/tmangle.nim
+tests/js/twritestacktrace.nim
+tests/lent/tbasic_lent_check.nim
+tests/misc/trunner.nim
+tests/misc/tstrace.nim
+tests/misc/twarningaserror.nim
+tests/parser/t20922.nim
+tests/pragmas/thintprocessing.nim
+tests/pragmas/tused.nim
+tests/pragmas/twarning_off.nim
+tests/stdlib/tos.nim
+tests/stdlib/tstackframes.nim
+tests/stdlib/tstats.nim
+tests/system/talloc.nim
+tests/testament/tshould_not_work.nim
+# broken on musl + llvm
+tests/coroutines/tgc.nim
+tests/coroutines/twait.nim
+tests/misc/t18077.nim
+tests/misc/temit.nim
+tests/nimdoc/t15916.nim
+tests/nimdoc/trunnableexamples.nim
+tests/nimdoc/trunnableexamples2.nim
+tests/objects/tobjcov.nim
+tests/objects/toop1.nim
+tests/stdlib/tencodings.nim
+tests/stdlib/tgetaddrinfo.nim
+tests/stdlib/tstdlib_various.nim
+tests/stdlib/tstreams.nim
+tests/stdlib/ttimes.nim
+tests/vm/tvmmisc.nim
+# require network
+tests/stdlib/thttpclient.nim
+tests/stdlib/tnetconnect.nim
+tests/stdlib/tssl.nim
+# don't work without megatest
+tests/misc/tjoinable.nim
+tests/testament/tjoinable.nim
+# don't work with "--hint:all:off" hack
+tests/concepts/t3330.nim
+tests/stylecheck/t20397_2.nim
+tests/stylecheck/treject.nim
+tests/stylecheck/tusages.nim
+# need external dependencies
+tests/manyloc/keineschweine/keineschweine.nim
+tests/manyloc/nake/nakefile.nim
+tests/niminaction/Chapter7/Tweeter/src/tweeter.nim
+# need functional valgrind
+tests/destructor/tnewruntime_strutils.nim
+tests/destructor/tv2_raise.nim
+tests/views/tsplit_into_openarray.nim
diff --git a/dev-lang/nim/nim-2.0.4.ebuild b/dev-lang/nim/nim-2.0.4.ebuild
index 192bb90437ae..d91d6fed17c5 100644
--- a/dev-lang/nim/nim-2.0.4.ebuild
+++ b/dev-lang/nim/nim-2.0.4.ebuild
@@ -107,7 +107,7 @@ src_test() {
--hint:UserRaw:on
)
local -a testament_args=(
- --skipFrom:"${FILESDIR}/${PN}-1.6.14-testament-skipfile.txt"
+ --skipFrom:"${FILESDIR}/${PN}-2.0.4-testament-skipfile.txt"
--nim:"bin/nim"
--targets:"$(usex test-js 'c js' 'c')"
)