summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-08 11:24:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-08 13:03:26 +0200
commit7f7cf9de8d398a3f2f9062d4c9b8d2934c2d2296 (patch)
tree3d54f6d7f2288b0da5d807923a293a1bca62a5a0 /dev-lang/nim
parentdev-lang/nim: drop old 2.0.4 (diff)
downloadgentoo-7f7cf9de8d398a3f2f9062d4c9b8d2934c2d2296.tar.gz
gentoo-7f7cf9de8d398a3f2f9062d4c9b8d2934c2d2296.tar.bz2
gentoo-7f7cf9de8d398a3f2f9062d4c9b8d2934c2d2296.zip
dev-lang/nim: bump to 2.0.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-2.0.8.ebuild183
2 files changed, 184 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index 265d4a9b463f..ddc8d24e07ea 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,2 +1,3 @@
DIST nim-2.0.6.tar.xz 7668088 BLAKE2B 1cc2b3be355b236b467fa6629747de55b60b6d2f3e9d8bc584fa4f30ba842d68a0db984aff234df1299b0a782af1d464382bb37fa62c0c7a952e667bf0d3c3be SHA512 9668b34decb55fd27f0edb8c6dcdd2d8dbed00f71e8ce5c177422aedbcc359f4b943b29a38875f4715c1903a32b8388e2a4662d5ceb301349b23eb2277dbde1e
+DIST nim-2.0.8.tar.xz 7617556 BLAKE2B 96ab3e92c7c9d3dcb54de6528f2ae788f3ff4a927d693f2ca4917231441d85d12c8bda44c41c8f363979dbd0d8db54098648512caf7780bdc40e393c4f7803ec SHA512 e64abc379c046a9432515d1c8074a7e10ff72a1076663a5b7bdd39ae92852c98ba2cab96aa5e968fc31ca393e778e70b2392d6ab56bca7ac956d0176b4b69a83
DIST nim-atlas-0.8.0.tar.gz 59097 BLAKE2B 231b238ac3b15cc2c2d9ad927f80ae72d8ae4c649277515f32df6cc04275ccd38db5307d627572af547501e6522c06c86dc279dc3e13b5385f14e24032f6fe69 SHA512 747c13e2c5bd45a1dc6c1426f8c7637f638ada9dd4c9aa3edf4ef8367060e73226dc4bcde6380fac25ed47ebf4097fd223c72fadc3cceba8c71dd0f0571e47eb
diff --git a/dev-lang/nim/nim-2.0.8.ebuild b/dev-lang/nim/nim-2.0.8.ebuild
new file mode 100644
index 000000000000..524cd020c819
--- /dev/null
+++ b/dev-lang/nim/nim-2.0.8.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ATLAS_V="0.8.0"
+
+inherit bash-completion-r1 edo multiprocessing toolchain-funcs xdg-utils
+
+DESCRIPTION="Compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/
+ https://github.com/nim-lang/Nim/"
+SRC_URI="
+ https://nim-lang.org/download/${P}.tar.xz
+ https://github.com/nim-lang/atlas/archive/refs/tags/${ATLAS_V}.tar.gz
+ -> nim-atlas-${ATLAS_V}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test-js test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-db/sqlite:3
+ dev-libs/boehm-gc
+ dev-libs/libffi
+ dev-libs/libpcre:3
+ dev-libs/openssl
+ media-libs/libsdl
+ media-libs/libsfml
+ )
+"
+BDEPEND="
+ sys-process/parallel
+ test? (
+ test-js? (
+ net-libs/nodejs
+ )
+ )
+"
+
+src_configure() {
+ xdg_environment_reset # bug #667182
+
+ unset NIMBLE_DIR
+ tc-export CC CXX LD
+
+ mkdir "${HOME}/.parallel" || die
+ touch "${HOME}/.parallel/will-cite" || die "parallel setup failed"
+
+ cat > nim.cfg <<- EOF || die "Failed to create Nim config"
+ cc:"gcc"
+ gcc.exe:"$(tc-getCC)"
+ gcc.linkerexe:"$(tc-getCC)"
+ gcc.cpp.exe:"$(tc-getCXX)"
+ gcc.cpp.linkerexe:"$(tc-getCXX)"
+ gcc.options.speed:"${CFLAGS}"
+ gcc.options.size:"${CFLAGS}"
+ gcc.options.debug:"${CFLAGS}"
+ gcc.options.always:"${CPPFLAGS}"
+ gcc.options.linker:"${LDFLAGS}"
+ gcc.cpp.options.speed:"${CXXFLAGS}"
+ gcc.cpp.options.size:"${CXXFLAGS}"
+ gcc.cpp.options.debug:"${CXXFLAGS}"
+ gcc.cpp.options.always:"${CPPFLAGS}"
+ gcc.cpp.options.linker:"${LDFLAGS}"
+
+ $([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
+ -d:"release"
+ --parallelBuild:"$(makeopts_jobs)"
+
+ # some tests don't work with processing hints
+ --processing:"off"
+ EOF
+
+ cp -r "${WORKDIR}/atlas-${ATLAS_V}" "${S}/dist/atlas" || die
+}
+
+src_compile() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./build.sh --parallel "$(makeopts_jobs)"
+
+ ebegin "Waiting for unfinished parallel jobs"
+ while [[ ! -f "bin/nim" ]] ; do
+ sleep 3
+ done
+ sleep 10
+ eend 0
+
+ edo chmod +x ./bin/nim
+ edo ./bin/nim compile -d:release koch
+ edo ./koch boot -d:nimUseLinenoise -d:release --skipParentCfg:off
+ edo ./koch tools -d:release
+ edo ./bin/nim compile -d:release ./tools/niminst/niminst.nim
+}
+
+src_test() {
+ local -x PATH="${S}/bin:${PATH}"
+ local -a nimflags=(
+ # Leave only the safe hints enabled.
+ --hint:all:off
+ --hint:User:on
+ --hint:UserRaw:on
+ )
+ local -a testament_args=(
+ --skipFrom:"${FILESDIR}/${PN}-2.0.6-testament-skipfile.txt"
+ --nim:"bin/nim"
+ --targets:"$(usex test-js 'c js' 'c')"
+ )
+
+ [[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] \
+ && testament_args+=( --colors:off )
+
+ local -a categories
+ readarray -t categories < <(find tests -mindepth 1 -maxdepth 1 -type d -printf "%P\n" | sort)
+
+ # AdditionalCategories from "testament/categories.nim".
+ categories+=( debugger examples lib )
+
+ local test_return=0
+
+ local tcat
+ local checkpoint
+ for tcat in "${categories[@]}"; do
+ # Use checkpoints for less painful testing.
+ checkpoint="${T}/.testament-${tcat}"
+
+ [[ -f "${checkpoint}" ]] && continue
+
+ case "${tcat}" in
+ testdata )
+ :
+ ;;
+ arc | gc | ic | js | msgs | stylecheck \
+ | testament | untestable | objects | valgrind )
+ einfo "Skipped nim test category: ${tcat}"
+ ;;
+ * )
+ einfo "Running tests in category '${tcat}'"
+ nonfatal edo ./bin/testament "${testament_args[@]}" \
+ category "${tcat}" "${nimflags[@]}" \
+ || test_return=1
+ ;;
+ esac
+
+ touch "${checkpoint}" || die
+ done
+
+ [[ "${test_return}" -eq 1 ]] \
+ && die "tests failed, please inspect the failed test categories above"
+}
+
+src_install() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./koch install "${ED}/usr/lib"
+ dosym -r /usr/lib/nim/bin/nim /usr/bin/nim
+
+ # "./koch install" installs only "nim" binary but not the rest.
+ exeinto /usr/bin
+ local exe
+ while read -r exe ; do
+ einfo "Installing nim support tool: ${exe}"
+ doexe "${exe}"
+ done < <(find ./bin -type f -not -iname nim)
+
+ newbashcomp tools/nim.bash-completion nim
+ newbashcomp dist/nimble/nimble.bash-completion nimble
+
+ insinto /usr/share/zsh/site-functions
+ newins tools/nim.zsh-completion _nim
+ newins dist/nimble/nimble.zsh-completion _nimble
+
+ # Install the @nim-rebuild set for Portage.
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}/nim-sets.conf" nim.conf
+
+ einstalldocs
+}