summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 00:53:01 +0100
committerSam James <sam@gentoo.org>2023-05-31 00:53:51 +0100
commit49f74715b1cda34f8cbf3698f6b1b1394e19a149 (patch)
treeb8ea2fdf2596e2fc5b5ebcf820d04f282ec025d2 /dev-lang/orc
parentdev-lang/go: Stabilize 1.20.4 arm64, #906570 (diff)
downloadgentoo-49f74715b1cda34f8cbf3698f6b1b1394e19a149.tar.gz
gentoo-49f74715b1cda34f8cbf3698f6b1b1394e19a149.tar.bz2
gentoo-49f74715b1cda34f8cbf3698f6b1b1394e19a149.zip
dev-lang/orc: add 0.4.34
No static lib is installed now (fixed upstream) for orc-test. But I assume (not checked, at least not yet) that gst still needs the orc-test header. Bug: https://bugs.gentoo.org/645232 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/orc')
-rw-r--r--dev-lang/orc/Manifest1
-rw-r--r--dev-lang/orc/orc-0.4.34.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index 65a60609e2f1..698e5a27dc95 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1,3 +1,4 @@
DIST orc-0.4.31.tar.xz 177768 BLAKE2B f06fd6be70063ebc82b45c1801a53aab66b5fc8a85c33991602488ec8ed29f2271df20c3780655953cabe33e865530b1218aafa0592261bcc5dccc4a4b3945e7 SHA512 4e97597e70982dbfc239d1ef9a8913b0155e5aaac15d91162d7f73a1095bd944e27fbe6d6194b9f74af07b985a44b1d9dddbe917425e1ad9e8da17ce86495696
DIST orc-0.4.32.tar.xz 180340 BLAKE2B fca41f0fc46bb6a841eb37f0f403afd0850053f93d34d50ba61c2e50c5029be7cb4fa0ba03828d87275aae1b4be2d968c32318d5d895ca7adf0f5edaf1f89efd SHA512 63e2ab05bc23e07cd5c1ed3192515ec3b1f666abb4f9ea5de4bd72461f3a5d7066860e2ad38f35d0acd81fadfa06f2a18d61838eae89c74dec6a78099a343567
DIST orc-0.4.33.tar.xz 199024 BLAKE2B 45518ff948f794c5a0eb14ddd462b58760d178267da34fd449a20d1bef4f7d6378b499efe1c7782e83c55be060b6f67023074cf8134e6a5ce129921324562c9b SHA512 ae8adce5dd62f4054879e6f2db76ce8a7959fd32fef0fb99f73f450ff58c5237e15bca764f6780309a163e40afcf400345f12b0aed5b88dc698064e44f8eede0
+DIST orc-0.4.34.tar.xz 202628 BLAKE2B b741e9bd5c0f0f3e56fad2f8a9bc10ce4a503a936eb2d64c4acf8ea5a69aaefc54edbd037846343181fb4f5f54bcd4409e5d4ee993ae09d266bdf37bcb86114a SHA512 ea6ce72398fad7569b97afe8e635402a7cc6d5e27b57c27fd76d85ccdf971391b52187297e5849e50ce1031691e9748f2cc312cb39bd0c6ac23c00ac6d96cb41
diff --git a/dev-lang/orc/orc-0.4.34.ebuild b/dev-lang/orc/orc-0.4.34.ebuild
new file mode 100644
index 000000000000..f3ef85f1507b
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.34.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+RESTRICT="!test? ( test )"
+IUSE="gtk-doc static-libs test"
+
+BDEPEND="
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.3
+ )
+"
+
+multilib_src_configure() {
+ # FIXME: handle backends per arch? What about cross-compiling for the other arches?
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dorc-backend=all
+ -Dorc-test=enabled
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ $(meson_native_use_feature gtk-doc gtk_doc)
+ $(meson_feature test tests)
+ -Dtools=enabled # requires orc-test
+ )
+ meson_src_configure
+}