summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-lang/rakudo
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/rakudo')
-rw-r--r--dev-lang/rakudo/rakudo-2018.06.ebuild3
-rw-r--r--dev-lang/rakudo/rakudo-2018.08.ebuild3
-rw-r--r--dev-lang/rakudo/rakudo-2018.09.ebuild3
-rw-r--r--dev-lang/rakudo/rakudo-2018.12.ebuild1
-rw-r--r--dev-lang/rakudo/rakudo-2019.03.ebuild1
-rw-r--r--dev-lang/rakudo/rakudo-9999.ebuild3
6 files changed, 10 insertions, 4 deletions
diff --git a/dev-lang/rakudo/rakudo-2018.06.ebuild b/dev-lang/rakudo/rakudo-2018.06.ebuild
index 5d27b8d2e3cd..cd8697211547 100644
--- a/dev-lang/rakudo/rakudo-2018.06.ebuild
+++ b/dev-lang/rakudo/rakudo-2018.06.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
diff --git a/dev-lang/rakudo/rakudo-2018.08.ebuild b/dev-lang/rakudo/rakudo-2018.08.ebuild
index 5d27b8d2e3cd..cd8697211547 100644
--- a/dev-lang/rakudo/rakudo-2018.08.ebuild
+++ b/dev-lang/rakudo/rakudo-2018.08.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
diff --git a/dev-lang/rakudo/rakudo-2018.09.ebuild b/dev-lang/rakudo/rakudo-2018.09.ebuild
index 4b639192fdbc..cd8697211547 100644
--- a/dev-lang/rakudo/rakudo-2018.09.ebuild
+++ b/dev-lang/rakudo/rakudo-2018.09.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
diff --git a/dev-lang/rakudo/rakudo-2018.12.ebuild b/dev-lang/rakudo/rakudo-2018.12.ebuild
index 6342a84cd882..cd8697211547 100644
--- a/dev-lang/rakudo/rakudo-2018.12.ebuild
+++ b/dev-lang/rakudo/rakudo-2018.12.ebuild
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
diff --git a/dev-lang/rakudo/rakudo-2019.03.ebuild b/dev-lang/rakudo/rakudo-2019.03.ebuild
index 6342a84cd882..cd8697211547 100644
--- a/dev-lang/rakudo/rakudo-2019.03.ebuild
+++ b/dev-lang/rakudo/rakudo-2019.03.ebuild
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
diff --git a/dev-lang/rakudo/rakudo-9999.ebuild b/dev-lang/rakudo/rakudo-9999.ebuild
index 070e46942a8d..bc57e9847276 100644
--- a/dev-lang/rakudo/rakudo-9999.ebuild
+++ b/dev-lang/rakudo/rakudo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,6 +21,7 @@ LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"
CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"