summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-07-13 09:46:52 +0200
committerHans de Graaff <graaff@gentoo.org>2024-07-13 09:47:48 +0200
commit5766128be9c98956afbc367174353b11cefccf83 (patch)
tree2c2dd83bc49db63e55378ca62be7bcdc8d21b60b /dev-lang/ruby
parentdev-python/portalocker: Mark for ALLARCHES (diff)
downloadgentoo-5766128be9c98956afbc367174353b11cefccf83.tar.gz
gentoo-5766128be9c98956afbc367174353b11cefccf83.tar.bz2
gentoo-5766128be9c98956afbc367174353b11cefccf83.zip
dev-lang/ruby: avoid broken readline test on arm
Backport unreleased upstream fix by matoro. Closes: https://bugs.gentoo.org/935871 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/files/3.2/020-arm-readline-test.patch32
-rw-r--r--dev-lang/ruby/ruby-3.2.4-r1.ebuild1
-rw-r--r--dev-lang/ruby/ruby-3.2.4.ebuild1
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/3.2/020-arm-readline-test.patch b/dev-lang/ruby/files/3.2/020-arm-readline-test.patch
new file mode 100644
index 000000000000..4edbc7b2b0c5
--- /dev/null
+++ b/dev-lang/ruby/files/3.2/020-arm-readline-test.patch
@@ -0,0 +1,32 @@
+From dd77934ca6e2e8b2b894f2460017323b33b619b6 Mon Sep 17 00:00:00 2001
+From: matoro <matoro@users.noreply.github.com>
+Date: Thu, 23 May 2024 16:10:32 -0400
+Subject: [PATCH] [ruby/readline-ext] Skip test_interrupt_in_other_thread on
+ arm32-linux
+
+This is a combination of main Ruby commit
+https://github.com/ruby/ruby/commit/aefc98891c42024039f19ef45bdfe93fbc590b7c
+and my PR correcting the regex https://github.com/ruby/ruby/pull/10819.
+Upstream Ruby requests that changes to this test go to readline-ext repo
+before being backported to 3.2 branch.
+
+https://github.com/ruby/readline-ext/commit/868f873a78
+---
+ test/readline/test_readline.rb | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/readline/test_readline.rb b/test/readline/test_readline.rb
+index 7838f4f52e864e..ab70e4371122f0 100644
+--- a/test/readline/test_readline.rb
++++ b/test/readline/test_readline.rb
+@@ -496,8 +496,8 @@ def test_interrupt_in_other_thread
+ # Maybe the same issue: https://github.com/facebookresearch/nle/issues/120
+ omit if /i[3-6]86-linux/ =~ RUBY_PLATFORM
+
+- # Skip arm32-linux (Travis CI).
+- omit "Skip arm32-linux" if /armv.+l-linux/ =~ RUBY_PLATFORM
++ # Skip arm32-linux (Travis CI). See aefc988 in main ruby repo.
++ omit "Skip arm32-linux" if /armv[0-9+][a-z]-linux/ =~ RUBY_PLATFORM
+
+ if defined?(TestReadline) && self.class == TestReadline
+ use = "use_ext_readline"
diff --git a/dev-lang/ruby/ruby-3.2.4-r1.ebuild b/dev-lang/ruby/ruby-3.2.4-r1.ebuild
index 567f50286b60..e469c52ff3e3 100644
--- a/dev-lang/ruby/ruby-3.2.4-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4-r1.ebuild
@@ -79,6 +79,7 @@ PDEPEND="
src_prepare() {
eapply "${FILESDIR}"/"${SLOT}"/010*.patch
eapply "${FILESDIR}"/"${SLOT}"/011*.patch
+ eapply "${FILESDIR}"/"${SLOT}"/020*.patch
eapply "${FILESDIR}"/"${SLOT}"/902*.patch
if use elibc_musl ; then
diff --git a/dev-lang/ruby/ruby-3.2.4.ebuild b/dev-lang/ruby/ruby-3.2.4.ebuild
index 029b41caa4e7..9d52787b6b18 100644
--- a/dev-lang/ruby/ruby-3.2.4.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4.ebuild
@@ -79,6 +79,7 @@ PDEPEND="
src_prepare() {
eapply "${FILESDIR}"/"${SLOT}"/010*.patch
eapply "${FILESDIR}"/"${SLOT}"/011*.patch
+ eapply "${FILESDIR}"/"${SLOT}"/020*.patch
eapply "${FILESDIR}"/"${SLOT}"/902*.patch
if use elibc_musl ; then