summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-07-13 09:04:51 +0200
committerHans de Graaff <graaff@gentoo.org>2024-07-13 09:37:41 +0200
commite1f377c62917fc7372230435cc1590ed65146ff0 (patch)
treec8e0e561a4f0e8efebb58e4ae81e596a49b66829 /dev-lang/ruby
parentdev-python/hatchling: Stabilize 1.25.0 ALLARCHES, #935950 (diff)
downloadgentoo-e1f377c62917fc7372230435cc1590ed65146ff0.tar.gz
gentoo-e1f377c62917fc7372230435cc1590ed65146ff0.tar.bz2
gentoo-e1f377c62917fc7372230435cc1590ed65146ff0.zip
dev-lang/ruby/files/3.0: remove obsolete patch files
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/files/3.0/001-socksocket-fix.patch15
-rw-r--r--dev-lang/ruby/files/3.0/010-default-gem-location.patch20
-rw-r--r--dev-lang/ruby/files/3.0/900-musl-coroutine.patch28
-rw-r--r--dev-lang/ruby/files/3.0/901-musl-stacksize.patch26
-rw-r--r--dev-lang/ruby/files/3.0/902-hppa-pthread-stack-size.patch54
5 files changed, 0 insertions, 143 deletions
diff --git a/dev-lang/ruby/files/3.0/001-socksocket-fix.patch b/dev-lang/ruby/files/3.0/001-socksocket-fix.patch
deleted file mode 100644
index 1a79e25491cc..000000000000
--- a/dev-lang/ruby/files/3.0/001-socksocket-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix compilation with socks5 USE flag.
-
-Patch by Phobos Kappa in https://bugs.gentoo.org/762253
-
---- a/ext/socket/sockssocket.c 2020-12-25 05:33:01.000000000 +0200
-+++ b/ext/socket/sockssocket.c 2020-12-28 15:42:50.310029778 +0200
-@@ -34,7 +34,7 @@
- init = 1;
- }
-
-- return rsock_init_inetsock(sock, host, port, Qnil, Qnil, INET_SOCKS, Qnil);
-+ return rsock_init_inetsock(sock, host, port, Qnil, Qnil, INET_SOCKS, Qnil, Qnil);
- }
-
- #ifdef SOCKS5
diff --git a/dev-lang/ruby/files/3.0/010-default-gem-location.patch b/dev-lang/ruby/files/3.0/010-default-gem-location.patch
deleted file mode 100644
index 060579b4f339..000000000000
--- a/dev-lang/ruby/files/3.0/010-default-gem-location.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/tool/rbinstall.rb.~1~ 2020-12-25 04:33:01.000000000 +0100
-+++ b/tool/rbinstall.rb 2020-12-25 10:05:34.629096405 +0100
-@@ -897,7 +897,7 @@
- end
-
- def install_default_gem(dir, srcdir)
-- gem_dir = Gem.default_dir
-+ gem_dir = ENV['GEM_DESTDIR']
- install_dir = with_destdir(gem_dir)
- prepare "default gems from #{dir}", gem_dir
- makedirs(Gem.ensure_default_gem_subdirectories(install_dir, $dir_mode).map {|d| File.join(gem_dir, d)})
-@@ -943,7 +943,7 @@
- end
-
- install?(:ext, :comm, :gem, :'bundled-gems') do
-- gem_dir = Gem.default_dir
-+ gem_dir = ENV['GEM_DESTDIR']
- install_dir = with_destdir(gem_dir)
- prepare "bundled gems", gem_dir
- makedirs(Gem.ensure_gem_subdirectories(install_dir, $dir_mode).map {|d| File.join(gem_dir, d)})
diff --git a/dev-lang/ruby/files/3.0/900-musl-coroutine.patch b/dev-lang/ruby/files/3.0/900-musl-coroutine.patch
deleted file mode 100644
index a323cdd6e770..000000000000
--- a/dev-lang/ruby/files/3.0/900-musl-coroutine.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Adapted for Gentoo version 3.0.2
-
-From b570e7de87aaad8c903176d835e8124127f627b3 Mon Sep 17 00:00:00 2001
-From: Andrew Aladjev <aladjev.andrew@gmail.com>
-Date: Sat, 26 Sep 2020 12:58:06 +0300
-Subject: [PATCH] fixed default coroutine selection for musl
-
----
- configure.ac | 5 ++++-
- coroutine/copy/Context.c | 2 ++
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index ab5d532c103b..084f0936c006 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2364,7 +2364,10 @@
- rb_cv_coroutine=copy
- ],
- [
-- rb_cv_coroutine=ucontext
-+ AC_CHECK_FUNCS([getcontext swapcontext makecontext],
-+ [rb_cv_coroutine=ucontext],
-+ [rb_cv_coroutine=copy; break]
-+ )
- ]
- )
- AC_MSG_RESULT(${rb_cv_coroutine})
diff --git a/dev-lang/ruby/files/3.0/901-musl-stacksize.patch b/dev-lang/ruby/files/3.0/901-musl-stacksize.patch
deleted file mode 100644
index e5fcfce2195e..000000000000
--- a/dev-lang/ruby/files/3.0/901-musl-stacksize.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-musl has a conservative stacksize, as compared to glibc, so treat it
-like other systems with such stacksize
-
-diff --git a/thread_pthread.c b/thread_pthread.c
-index 951885ffa0..e2d662143b 100644
---- a/thread_pthread.c
-+++ b/thread_pthread.c
-@@ -721,7 +721,7 @@ ruby_init_stack(volatile VALUE *addr
- {
- native_main_thread.id = pthread_self();
-
--#if MAINSTACKADDR_AVAILABLE
-+#if MAINSTACKADDR_AVAILABLE && !(defined(__linux__) && !defined(__GLIBC__))
- if (native_main_thread.stack_maxsize) return;
- {
- void* stackaddr;
-@@ -1680,7 +1680,7 @@ ruby_stack_overflowed_p(const rb_thread_t *th, const void *addr)
-
- #ifdef STACKADDR_AVAILABLE
- if (get_stack(&base, &size) == 0) {
--# ifdef __APPLE__
-+# if defined(__APPLE__) || (defined(__linux__) && !defined(__GLIBC__))
- if (pthread_equal(th->thread_id, native_main_thread.id)) {
- struct rlimit rlim;
- if (getrlimit(RLIMIT_STACK, &rlim) == 0 && rlim.rlim_cur > size) {
-
diff --git a/dev-lang/ruby/files/3.0/902-hppa-pthread-stack-size.patch b/dev-lang/ruby/files/3.0/902-hppa-pthread-stack-size.patch
deleted file mode 100644
index 7978566afc7e..000000000000
--- a/dev-lang/ruby/files/3.0/902-hppa-pthread-stack-size.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://bugs.gentoo.org/701494
-
-From 794b6fce94343c4f9dceca5d08224b0fb364fde8 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Fri, 7 Apr 2023 11:46:12 +0100
-Subject: [PATCH] thread_pthread: Grow main_stack if required (fixes tests on
- HPPA)
-
-On HPPA, test_insns.rb fails (along with various Ruby gems) with
-'stack level too deep (SystemStackError)'. This turns out to be because HPPA
-defaults to a small(er) stack.
-
-With this change, most of Ruby's test suite now passes on HPPA.
-
-Thanks to both Dave and Helge for the investigation and coming up with the
-patch.
-
-Bug: https://bugs.gentoo.org/701494
-Bug: https://bugs.debian.org/881773
-Bug: https://bugs.debian.org/881772 (for PPC64)
-Bug: https://github.com/rack/rack/issues/1640
-Thanks-to: John David Anglin <dave.anglin@bell.net>
-Thanks-to: Helge Deller <deller@gmx.de>
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/thread_pthread.c
-+++ b/thread_pthread.c
-@@ -681,8 +681,22 @@ size_t pthread_get_stacksize_np(pthread_t);
- # define MAINSTACKADDR_AVAILABLE 0
- # endif
- #endif
--#if MAINSTACKADDR_AVAILABLE && !defined(get_main_stack)
--# define get_main_stack(addr, size) get_stack(addr, size)
-+#if MAINSTACKADDR_AVAILABLE
-+static int get_stack(void **, size_t *);
-+static int
-+get_main_stack(void **addr, size_t *size)
-+{
-+ int ret = get_stack(addr, size);
-+
-+#ifdef __hppa__
-+ /* On some architectures, the initial stack size may be too small, but fortunately,
-+ it's growable. Bump it up to the minimum needed if it is too small. */
-+ if (*size < RUBY_VM_THREAD_VM_STACK_SIZE)
-+ *size = RUBY_VM_THREAD_VM_STACK_SIZE;
-+#endif
-+
-+ return ret;
-+}
- #endif
-
- #ifdef STACKADDR_AVAILABLE
---
-2.40.0
-