summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-01-13 17:47:46 +0600
committerSam James <sam@gentoo.org>2023-01-14 19:14:51 +0000
commit766ffdacc8e269ad975a010bb9124024e7272fd7 (patch)
tree0bc2ec2ed1bf312b27ccdc2cbb3d9013b9e0953a /dev-lang/zig/files
parentnet-dns/libidn2: fix build with lld-16 (diff)
downloadgentoo-766ffdacc8e269ad975a010bb9124024e7272fd7.tar.gz
gentoo-766ffdacc8e269ad975a010bb9124024e7272fd7.tar.bz2
gentoo-766ffdacc8e269ad975a010bb9124024e7272fd7.zip
dev-lang/zig: fix patch from previous commit
I'm sorry for possible incovenience caused by this (I hope that it was, since it didn't look SO bad). Explained in and rebased upstream PR too. Fixes: 28fcae31f91eb30b62c8d55b39207238d377f0c2 Closes: https://bugs.gentoo.org/890457 Closes: https://bugs.gentoo.org/890459 Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/zig/files')
-rw-r--r--dev-lang/zig/files/zig-0.10.0-build-dir-install-stage3.patch24
1 files changed, 19 insertions, 5 deletions
diff --git a/dev-lang/zig/files/zig-0.10.0-build-dir-install-stage3.patch b/dev-lang/zig/files/zig-0.10.0-build-dir-install-stage3.patch
index c44632f5111e..5704e4ba7921 100644
--- a/dev-lang/zig/files/zig-0.10.0-build-dir-install-stage3.patch
+++ b/dev-lang/zig/files/zig-0.10.0-build-dir-install-stage3.patch
@@ -1,18 +1,32 @@
From: Eric Joldasov <bratishkaerik@getgoogleoff.me>
Install 'zig' binary in 'build_dir/stage3' directory so that we can find it and use for testing.
+Also split "add_custom_target(stage3 ALL" and command that it invokes, so that it won't retry it during installation,
+as target will be considered not out-of-date. (Bug https://bugs.gentoo.org/890457 and https://bugs.gentoo.org/890459).
Upstream PR https://github.com/ziglang/zig/pull/14255.
+
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1094,7 +1094,7 @@ set(ZIG_BUILD_ARGS
+@@ -1094,10 +1094,14 @@ set(ZIG_BUILD_ARGS
)
add_custom_target(stage3 ALL
- COMMAND zig2 build compile ${ZIG_BUILD_ARGS}
-+ COMMAND zig2 build --prefix "${CMAKE_BINARY_DIR}/stage3" ${ZIG_BUILD_ARGS}
- DEPENDS zig2
- COMMENT STATUS "Building stage3"
- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
+- DEPENDS zig2
+- COMMENT STATUS "Building stage3"
+- WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
++ DEPENDS "${CMAKE_BINARY_DIR}/stage3/bin/zig"
++)
++
++add_custom_command(
++ OUTPUT "${CMAKE_BINARY_DIR}/stage3/bin/zig"
++ COMMAND zig2 build --prefix "${CMAKE_BINARY_DIR}/stage3" ${ZIG_BUILD_ARGS}
++ COMMENT STATUS "Building stage3"
++ WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
+ )
+
+ install(CODE "set(ZIG_EXECUTABLE \"${ZIG_EXECUTABLE}\")")
+
--- a/build.zig
+++ b/build.zig
@@ -148,10 +148,6 @@ pub fn build(b: *Builder) !void {