summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-06-09 12:08:05 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-11 08:29:51 +0300
commit50ec6920ed92ed9fc952d83698ba800faceba728 (patch)
tree5b2e9994da4085c206d034e7c955e906bc3908be /dev-lang
parentdev-lang/uasm: fix makefile dependency order (diff)
downloadgentoo-50ec6920ed92ed9fc952d83698ba800faceba728.tar.gz
gentoo-50ec6920ed92ed9fc952d83698ba800faceba728.tar.bz2
gentoo-50ec6920ed92ed9fc952d83698ba800faceba728.zip
dev-lang/jwasm: fix makefile dependency order
Closes: https://bugs.gentoo.org/881519 Signed-off-by: NRK <nrk@disroot.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jwasm/files/makefile-dep-fix.patch22
-rw-r--r--dev-lang/jwasm/jwasm-2.13.ebuild7
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-lang/jwasm/files/makefile-dep-fix.patch b/dev-lang/jwasm/files/makefile-dep-fix.patch
new file mode 100644
index 000000000000..1b97a7c5aca4
--- /dev/null
+++ b/dev-lang/jwasm/files/makefile-dep-fix.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/881519
+
+diff --git a/GccUnix.mak b/GccUnix.mak
+index 3f53d5b..8eb434e 100644
+--- a/GccUnix.mak
++++ b/GccUnix.mak
+@@ -31,13 +31,13 @@ include gccmod.inc
+
+ #.c.o:
+ # $(CC) -c $(inc_dirs) $(c_flags) -o $(OUTD)/$*.o $<
+-$(OUTD)/%.o: %.c
++$(OUTD)/%.o: %.c | $(OUTD)
+ $(CC) -c $(inc_dirs) $(c_flags) -o $(OUTD)/$*.o $<
+
+ all: $(OUTD) $(OUTD)/$(TARGET1)
+
+ $(OUTD):
+- mkdir $(OUTD)
++ mkdir -p $(OUTD)
+
+ $(OUTD)/$(TARGET1) : $(OUTD)/main.o $(proj_obj)
+ ifeq ($(DEBUG),0)
diff --git a/dev-lang/jwasm/jwasm-2.13.ebuild b/dev-lang/jwasm/jwasm-2.13.ebuild
index ecb666549892..0242aa2b604c 100644
--- a/dev-lang/jwasm/jwasm-2.13.ebuild
+++ b/dev-lang/jwasm/jwasm-2.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,10 @@ BDEPEND=""
S="${WORKDIR}/JWasm-${PV}"
-PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.11-types-test.patch
+ "${FILESDIR}/makefile-dep-fix.patch"
+)
src_prepare() {
default