summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-10-22 10:36:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-10-22 19:32:45 +0300
commit69f2faa2b9b1202f91f4f7db7439321fe5e70622 (patch)
treeb3e1de4bbccc2b4180304b90b06c90ef18281b9a /dev-lang
parentapp-emulation/qemu: remove unused patches (diff)
downloadgentoo-69f2faa2b9b1202f91f4f7db7439321fe5e70622.tar.gz
gentoo-69f2faa2b9b1202f91f4f7db7439321fe5e70622.tar.bz2
gentoo-69f2faa2b9b1202f91f4f7db7439321fe5e70622.zip
dev-lang/ispc: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/33450 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch16
-rw-r--r--dev-lang/ispc/files/ispc-1.18.0-llvm.patch39
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch b/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch
deleted file mode 100644
index 127b7095a778..000000000000
--- a/dev-lang/ispc/files/ispc-1.18.0-curses-cmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -530,11 +530,8 @@ else()
- else()
- find_package(Curses REQUIRED)
- find_package(ZLIB REQUIRED)
-- if (CURSES_EXTRA_LIBRARY)
-- # this contains the tinfo library, if found
-- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
-- endif()
-- target_link_libraries(${PROJECT_NAME} pthread ${ZLIB_LIBRARIES} ${CURSES_CURSES_LIBRARY})
-+ set(CURSES_NEED_NCURSES ON)
-+ target_link_libraries(${PROJECT_NAME} pthread ${ZLIB_LIBRARIES} ${CURSES_LIBRARIES})
- endif()
- endif()
-
diff --git a/dev-lang/ispc/files/ispc-1.18.0-llvm.patch b/dev-lang/ispc/files/ispc-1.18.0-llvm.patch
deleted file mode 100644
index 7303ac0fd6e8..000000000000
--- a/dev-lang/ispc/files/ispc-1.18.0-llvm.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 13e66268..27ff8364 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -218,7 +218,7 @@ if (WASM_ENABLED)
- list(APPEND ISPC_TARGETS wasm-i32x4)
- endif()
-
--set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
-+set(CLANG_LIBRARY_LIST clang clang-cpp)
- set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp)
-
- if (X86_ENABLED)
-@@ -402,11 +402,8 @@ if (ISPC_USE_ASAN)
- endif()
-
- # Link against Clang libraries
--foreach(clangLib ${CLANG_LIBRARY_LIST})
-- find_library(${clangLib}Path NAMES ${clangLib} HINTS ${LLVM_LIBRARY_DIRS})
-- list(APPEND CLANG_LIBRARY_FULL_PATH_LIST ${${clangLib}Path})
--endforeach()
--target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_FULL_PATH_LIST})
-+find_package(Clang REQUIRED)
-+target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_LIST})
-
- # Link against LLVM libraries
- target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST})
-diff --git a/src/llvmutil.cpp b/src/llvmutil.cpp
-index 06fab989..57a7130f 100644
---- a/src/llvmutil.cpp
-+++ b/src/llvmutil.cpp
-@@ -42,6 +42,7 @@
- #include <llvm/IR/BasicBlock.h>
- #include <llvm/IR/Instructions.h>
- #include <llvm/IR/Module.h>
-+#include <llvm/Support/raw_ostream.h>
-
- #ifdef ISPC_GENX_ENABLED
- #include <llvm/GenXIntrinsics/GenXIntrinsics.h>