summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-09-19 22:07:40 -0400
committerMike Gilbert <floppym@gentoo.org>2015-09-19 22:07:53 -0400
commitc0d97a27e1a8ab3e695624d222c46bc80a6de618 (patch)
treee28688ee4f1d1a08976f3d97e8cb09edf2e8cd87 /dev-lang
parentdev-lang/mmix: Compilation fix for format-security, bug #533694 (diff)
downloadgentoo-c0d97a27e1a8ab3e695624d222c46bc80a6de618.tar.gz
gentoo-c0d97a27e1a8ab3e695624d222c46bc80a6de618.tar.bz2
gentoo-c0d97a27e1a8ab3e695624d222c46bc80a6de618.zip
dev-lang/python: Fix cross-compiling for 3.5
Package-Manager: portage-2.2.20_p169_p6532
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/3.5-secondary-targets.patch19
-rw-r--r--dev-lang/python/python-3.5.0.ebuild4
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/python/files/3.5-secondary-targets.patch b/dev-lang/python/files/3.5-secondary-targets.patch
new file mode 100644
index 000000000000..eb3b0c71e7d5
--- /dev/null
+++ b/dev-lang/python/files/3.5-secondary-targets.patch
@@ -0,0 +1,19 @@
+Mark all targets as "secondary"
+
+This allows make to avoid rebuilding unnecessary intermediate files, which
+is useful when cross-compiling.
+
+See Parser/pgen and Programs/_freeze_importlib in Makefile.pre.in.
+
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1672,6 +1672,8 @@
+ .PHONY: smelly funny patchcheck touch altmaninstall commoninstall
+ .PHONY: gdbhooks
+
++.SECONDARY:
++
+ # IF YOU PUT ANYTHING HERE IT WILL GO AWAY
+ # Local Variables:
+ # mode: makefile
diff --git a/dev-lang/python/python-3.5.0.ebuild b/dev-lang/python/python-3.5.0.ebuild
index ca56f88c9fc7..1dcd76917504 100644
--- a/dev-lang/python/python-3.5.0.ebuild
+++ b/dev-lang/python/python-3.5.0.ebuild
@@ -66,6 +66,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
+ epatch "${FILESDIR}/3.5-secondary-targets.patch"
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
configure.ac \
@@ -171,6 +172,9 @@ src_configure() {
}
src_compile() {
+ # Avoid regenerating these for cross-compiles
+ touch Include/graminit.h Python/graminit.c Python/importlib.h Python/importlib_external.h || die
+
cd "${BUILD_DIR}" || die
emake CPPFLAGS= CFLAGS= LDFLAGS=