summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-02 00:21:39 -0400
committerSam James <sam@gentoo.org>2024-05-02 05:31:31 +0100
commit2343f3907d70a08674be77218f76ede6cb91f7ff (patch)
treee6ab33507fe548e0ee1bd547a23315e130b3f791 /dev-lisp
parentdev-lisp/clisp: mark as LTO-unsafe (diff)
downloadgentoo-2343f3907d70a08674be77218f76ede6cb91f7ff.tar.gz
gentoo-2343f3907d70a08674be77218f76ede6cb91f7ff.tar.bz2
gentoo-2343f3907d70a08674be77218f76ede6cb91f7ff.zip
dev-lisp/roswell: mark as LTO-unsafe
Listen, I definitely know it's LTO-unsafe. I can't actually get it to compile, but either way, it's definitely LTO-unsafe... The next compilation error is: ``` /usr/lib/gcc/x86_64-pc-linux-gnu/13/../../../../x86_64-pc-linux-gnu/bin/ld: warning: resources.o: missing .note.GNU-stack section implies executable stack /usr/lib/gcc/x86_64-pc-linux-gnu/13/../../../../x86_64-pc-linux-gnu/bin/ld: NOTE: This behaviour is deprecated and will be removed in a future version of the linker resources.o:(.rsrc$01+0x80): dangerous relocation: R_AMD64_IMAGEBASE with __ImageBase undefined resources.o:(.rsrc$01+0x90): dangerous relocation: R_AMD64_IMAGEBASE with __ImageBase undefined collect2: error: ld returned 1 exit status make[2]: *** [Makefile:436: ros] Error 1 ``` As you can tell from the linker error, it appears to be lisp code... if anyone can figure out why it happens you're welcome to it but I am not spending more time on lisp so this is me backing away now that the LTO bug can be closed. So long! Closes: https://bugs.gentoo.org/856106 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/roswell/roswell-20.05.14.106.ebuild13
-rw-r--r--dev-lisp/roswell/roswell-21.10.14.111.ebuild13
-rw-r--r--dev-lisp/roswell/roswell-22.12.14.113.ebuild11
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-lisp/roswell/roswell-20.05.14.106.ebuild b/dev-lisp/roswell/roswell-20.05.14.106.ebuild
index 76c9e1152f1d..e7f55bcbac23 100644
--- a/dev-lisp/roswell/roswell-20.05.14.106.ebuild
+++ b/dev-lisp/roswell/roswell-20.05.14.106.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A lisp installer and launcher for major environment"
HOMEPAGE="https://github.com/roswell/roswell"
@@ -20,3 +20,12 @@ src_prepare() {
default
eautoreconf
}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/856106
+ # https://github.com/roswell/roswell/issues/584
+ filter-lto
+
+ default
+}
diff --git a/dev-lisp/roswell/roswell-21.10.14.111.ebuild b/dev-lisp/roswell/roswell-21.10.14.111.ebuild
index 8dc066c33326..de8998f15f2a 100644
--- a/dev-lisp/roswell/roswell-21.10.14.111.ebuild
+++ b/dev-lisp/roswell/roswell-21.10.14.111.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A lisp installer and launcher for major environment"
HOMEPAGE="https://github.com/roswell/roswell"
@@ -23,3 +23,12 @@ src_prepare() {
default
eautoreconf
}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/856106
+ # https://github.com/roswell/roswell/issues/584
+ filter-lto
+
+ default
+}
diff --git a/dev-lisp/roswell/roswell-22.12.14.113.ebuild b/dev-lisp/roswell/roswell-22.12.14.113.ebuild
index e287f778cad6..de8998f15f2a 100644
--- a/dev-lisp/roswell/roswell-22.12.14.113.ebuild
+++ b/dev-lisp/roswell/roswell-22.12.14.113.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A lisp installer and launcher for major environment"
HOMEPAGE="https://github.com/roswell/roswell"
@@ -23,3 +23,12 @@ src_prepare() {
default
eautoreconf
}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/856106
+ # https://github.com/roswell/roswell/issues/584
+ filter-lto
+
+ default
+}