summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-13 23:51:44 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-13 23:53:11 +0100
commit46bf3e6e6e4316ba880e0fa983ef34008a10d368 (patch)
tree70dbc8248490825410f7be89d00e9b91660000f1 /dev-lua/luaevent
parentsys-apps/attr: Stabilize 2.4.48-r4 amd64, #753350 (diff)
downloadgentoo-46bf3e6e6e4316ba880e0fa983ef34008a10d368.tar.gz
gentoo-46bf3e6e6e4316ba880e0fa983ef34008a10d368.tar.bz2
gentoo-46bf3e6e6e4316ba880e0fa983ef34008a10d368.zip
dev-lua/luaevent: migrate to lua eclass
Closes: https://bugs.gentoo.org/752639 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luaevent')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6-r100.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild b/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
new file mode 100644
index 000000000000..b5d3f6052466
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.6-r100.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Binding of libevent for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-libs/libevent:0="
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ local mysedargs=(
+ -e "'s/CFLAGS =/CFLAGS +=/'"
+ -e "'s/LDFLAGS =/LDFLAGS +=/'"
+ -e "'s:-I\$(LUA_INC_DIR):\$(LUA_INC_DIR):'"
+ -i Makefile
+ )
+
+ eval sed ${mysedargs[@]} || die
+}
+
+lua_src_compile() {
+ tc-export CC
+
+ emake LUA_INC_DIR="$(lua_get_CFLAGS)"
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ INSTALL_DIR_BIN="$(lua_get_cmod_dir)"
+ INSTALL_DIR_LUA="$(lua_get_lmod_dir)"
+ LUA_INC_DIR="$(lua_get_CFLAGS)"
+ )
+
+ emake ${myemakeargs[@]} install
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}