summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-22 21:44:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-22 21:44:11 +0200
commitb15c43cab1d82726b72fd03e37d8dbce1bd56e9c (patch)
tree7e81c1b60eeadf25856ffd423911c01003143ba4 /dev-lua
parentapp-misc/trash-cli: drop 0.21.10.24 (diff)
downloadgentoo-b15c43cab1d82726b72fd03e37d8dbce1bd56e9c.tar.gz
gentoo-b15c43cab1d82726b72fd03e37d8dbce1bd56e9c.tar.bz2
gentoo-b15c43cab1d82726b72fd03e37d8dbce1bd56e9c.zip
dev-lua/penlight: add 1.13.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/penlight/Manifest1
-rw-r--r--dev-lua/penlight/penlight-1.13.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-lua/penlight/Manifest b/dev-lua/penlight/Manifest
index cd3bd3cfef19..b5ccc1fff9f4 100644
--- a/dev-lua/penlight/Manifest
+++ b/dev-lua/penlight/Manifest
@@ -1 +1,2 @@
DIST penlight-1.12.0.tar.gz 429587 BLAKE2B b8a659c051c1bb9406e9c20ad1da20029e3a141d8193c1d74e83c24b7089ee11c12bb1850c6abb08d7199dbe6d02f40ef8efdfaf2ba4fb16aa88b0218f1dbc65 SHA512 70628bd43a0ac4176704611e47c3a42c287c24aac98a0bc63071a192326e4ecab016a499ff9ab201a9e7d7848f26760f0a2ef87d46220df679b4f70a0fdc4aac
+DIST penlight-1.13.1.tar.gz 434059 BLAKE2B 09a509afc11ad28b88fc92e9f9237fef4d18fc4c5b8c401c6fc8b4e3765941534409e5e5c9c9a08e0ad1a8b08d635d9ef8b453ec602514e4365317e1b31bbf63 SHA512 de0a6a2f585f32bed234ef084d8fca9cee645eed3459aa3c39b885b46a05ae752b5c7ac3bb1957fef9519df2a11e250fc87d6d4d62ee6155be2742ad43a079fe
diff --git a/dev-lua/penlight/penlight-1.13.1.ebuild b/dev-lua/penlight/penlight-1.13.1.ebuild
new file mode 100644
index 000000000000..509ed4edd60e
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.13.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PN="Penlight"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/lunarmodules/Penlight"
+SRC_URI="https://github.com/lunarmodules/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}"
+
+RDEPEND="
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ ${DEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${DEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ # This is a demo app, not a real test
+ rm tests/test-app.lua || die
+
+ # Remove test for executing a non-existent command
+ sed -e '/most-likely-nonexistent-command/d' -i tests/test-utils3.lua || die
+}
+
+lua_src_test() {
+ "${ELUA}" run.lua || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r lua/pl
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}