summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Graph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Graph')
-rw-r--r--dev-perl/Graph/Graph-0.960.0-r1.ebuild21
-rw-r--r--dev-perl/Graph/Manifest1
-rw-r--r--dev-perl/Graph/metadata.xml29
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Graph/Graph-0.960.0-r1.ebuild b/dev-perl/Graph/Graph-0.960.0-r1.ebuild
new file mode 100644
index 000000000000..1253dd030187
--- /dev/null
+++ b/dev-perl/Graph/Graph-0.960.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JHI
+MODULE_VERSION=0.96
+inherit perl-module
+
+DESCRIPTION="Data structure and ops for directed graphs"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.05"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Graph/Manifest b/dev-perl/Graph/Manifest
new file mode 100644
index 000000000000..935ea072ab31
--- /dev/null
+++ b/dev-perl/Graph/Manifest
@@ -0,0 +1 @@
+DIST Graph-0.96.tar.gz 147629 SHA256 832efa8d483a484f2543a001a3996fcc04c9b37cfc2178d63f603fb0cf8f9727 SHA512 afcaa154473696e51310a9b0e1b1a48c29ce60fa3462d25c9fba1a5080a8205e2a734a6870a2d1770e3df88ffd5cde144861ea7ab794313df8c2a715e1540c67 WHIRLPOOL 23439672add86bc32646db4b295e67fa8a7e3982acf3482735a39b45008a5a2f828c6ab09bd83ab2a2d9861872ece61ac3d380f6e51ed26eb76f79cab8390327
diff --git a/dev-perl/Graph/metadata.xml b/dev-perl/Graph/metadata.xml
new file mode 100644
index 000000000000..646b85a2341a
--- /dev/null
+++ b/dev-perl/Graph/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Graph</remote-id>
+ <remote-id type="cpan-module">Graph</remote-id>
+ <remote-id type="cpan-module">Graph::AdjacencyMap</remote-id>
+ <remote-id type="cpan-module">Graph::AdjacencyMap::Heavy</remote-id>
+ <remote-id type="cpan-module">Graph::AdjacencyMap::Light</remote-id>
+ <remote-id type="cpan-module">Graph::AdjacencyMap::Vertex</remote-id>
+ <remote-id type="cpan-module">Graph::AdjacencyMatrix</remote-id>
+ <remote-id type="cpan-module">Graph::Attribute</remote-id>
+ <remote-id type="cpan-module">Graph::BitMatrix</remote-id>
+ <remote-id type="cpan-module">Graph::Directed</remote-id>
+ <remote-id type="cpan-module">Graph::MSTHeapElem</remote-id>
+ <remote-id type="cpan-module">Graph::Matrix</remote-id>
+ <remote-id type="cpan-module">Graph::SPTHeapElem</remote-id>
+ <remote-id type="cpan-module">Graph::TransitiveClosure</remote-id>
+ <remote-id type="cpan-module">Graph::TransitiveClosure::Matrix</remote-id>
+ <remote-id type="cpan-module">Graph::Traversal</remote-id>
+ <remote-id type="cpan-module">Graph::Traversal::BFS</remote-id>
+ <remote-id type="cpan-module">Graph::Traversal::DFS</remote-id>
+ <remote-id type="cpan-module">Graph::Undirected</remote-id>
+ <remote-id type="cpan-module">Graph::UnionFind</remote-id>
+ <remote-id type="cpan-module">Heap071::Elem</remote-id>
+ <remote-id type="cpan-module">Heap071::Fibonacci</remote-id>
+ </upstream>
+</pkgmetadata>