summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-01 01:13:43 +0400
committerSam James <sam@gentoo.org>2024-05-08 12:57:40 +0100
commit2ea388e6eb1b8cb40b91f5e0d11c58a4104cccf6 (patch)
treec035e79b655d355d0954e96f232cfb4646483fe5 /dev-php
parentmedia-sound/cdparanoia: Stabilize 3.10.2-r8 ppc64, #931560 (diff)
downloadgentoo-2ea388e6eb1b8cb40b91f5e0d11c58a4104cccf6.tar.gz
gentoo-2ea388e6eb1b8cb40b91f5e0d11c58a4104cccf6.tar.bz2
gentoo-2ea388e6eb1b8cb40b91f5e0d11c58a4104cccf6.zip
dev-php/pecl-yaml: Fix -Wincompatible-pointer-types in 2.2.3
Upstream patch [sam: Include revbump.] Closes: https://bugs.gentoo.org/922688 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36027 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-yaml/files/pecl-yaml-2.2.3-c99-incompatible-pointer-types.patch24
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-2.2.3-r1.ebuild (renamed from dev-php/pecl-yaml/pecl-yaml-2.2.3.ebuild)3
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-php/pecl-yaml/files/pecl-yaml-2.2.3-c99-incompatible-pointer-types.patch b/dev-php/pecl-yaml/files/pecl-yaml-2.2.3-c99-incompatible-pointer-types.patch
new file mode 100644
index 000000000000..f0f7421a7632
--- /dev/null
+++ b/dev-php/pecl-yaml/files/pecl-yaml-2.2.3-c99-incompatible-pointer-types.patch
@@ -0,0 +1,24 @@
+bug https://bugs.gentoo.org/922688
+upstream commit: https://github.com/php/pecl-file_formats-yaml/commit/e7bffc01c496ef36ce672c612984b13a27426788
+From e7bffc01c496ef36ce672c612984b13a27426788 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 6 Mar 2023 09:29:07 +0100
+Subject: [PATCH] Fix [-Wincompatible-pointer-types] warning
+
+---
+ parse.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/parse.c b/parse.c
+index e63f3d8..17f70ba 100644
+--- a/parse.c
++++ b/parse.c
+@@ -531,7 +531,7 @@ void handle_sequence (parser_state_t *state, zval *retval) {
+ /* apply callbacks to the collected node */
+ if (Y_FILTER_FAILURE == apply_filter(
+ retval, src_event, state->callbacks)) {
+- zval_ptr_dtor(&retval);
++ zval_ptr_dtor(retval);
+ ZVAL_UNDEF(retval);
+ goto done;
+ //TODO Sean-Der
diff --git a/dev-php/pecl-yaml/pecl-yaml-2.2.3.ebuild b/dev-php/pecl-yaml/pecl-yaml-2.2.3-r1.ebuild
index 64c9a699a0c2..1bee510816fb 100644
--- a/dev-php/pecl-yaml/pecl-yaml-2.2.3.ebuild
+++ b/dev-php/pecl-yaml/pecl-yaml-2.2.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,3 +18,4 @@ KEYWORDS="~amd64 ~arm64 ~x86"
DEPEND="dev-libs/libyaml"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-c99-incompatible-pointer-types.patch" )