summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-23 23:03:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-26 21:52:32 +0200
commit90bcaa3eeff706d331366801ba056656c8d1f743 (patch)
treecfca9326ffbe4b7093c661d0aace0e3fb3171e6f /dev-php
parentdev-php/pecl-imagick: add php8-2 (diff)
downloadgentoo-90bcaa3eeff706d331366801ba056656c8d1f743.tar.gz
gentoo-90bcaa3eeff706d331366801ba056656c8d1f743.tar.bz2
gentoo-90bcaa3eeff706d331366801ba056656c8d1f743.zip
dev-php/igbinary: add 3.2.9 (php8-2 support)
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/igbinary/Manifest1
-rw-r--r--dev-php/igbinary/igbinary-3.2.9.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-php/igbinary/Manifest b/dev-php/igbinary/Manifest
index 79719ceff369..4f64cc10d66d 100644
--- a/dev-php/igbinary/Manifest
+++ b/dev-php/igbinary/Manifest
@@ -1 +1,2 @@
DIST igbinary-3.2.7.tar.gz 248481 BLAKE2B 40936fb78b9f01d717daac78f8b707f902d78714e5202fbb1344042c2d30a3b723f9c5b6fd982f7a5002aab65e414ba7f9bda354fec4db82ba3f03fc09663a43 SHA512 1bdb60fa4ac76ef405b55b4a7e7f07c73ccc945a3fad8635934cf83a05ae554ac1a0b64c4b55229f0bd2a3269189d3266a492b064a0338fdb2bf4dfe5c3733e4
+DIST igbinary-3.2.9.tar.gz 251747 BLAKE2B d44711ffc195572a83a000f225776191e7b421e4be3065a668287f356d46fd11536af0a0969a0fc219c38d027f13aec16cfe41f15ea778ef087f7082daa9b8dc SHA512 2789f8517aaefa4e4e736592944361e8bad1ce50687aed161bb4e17bcdfbfec2320df8069c7b39704fa96c614727bd66fb65185b15f72f8c96bb5fda88f2e66f
diff --git a/dev-php/igbinary/igbinary-3.2.9.ebuild b/dev-php/igbinary/igbinary-3.2.9.ebuild
new file mode 100644
index 000000000000..b2f81fe8a0fa
--- /dev/null
+++ b/dev-php/igbinary/igbinary-3.2.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+PHP_EXT_INI="yes"
+PHP_EXT_NAME="${PN}"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/igbinary/igbinary"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"