summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 12:42:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 12:42:41 +0200
commit8f925be3a87892ee53a7330fb6f19534af753241 (patch)
tree983d92f7417a6572eb5025397b24e6dc20a5e606 /dev-python/click
parentdev-python/psutil: Fix one more test failure (diff)
downloadgentoo-8f925be3a87892ee53a7330fb6f19534af753241.tar.gz
gentoo-8f925be3a87892ee53a7330fb6f19534af753241.tar.bz2
gentoo-8f925be3a87892ee53a7330fb6f19534af753241.zip
dev-python/click: Bump to 7.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-7.1.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index b7ec92e2f003..3c29d833fd71 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,2 +1,3 @@
DIST click-6.7.tar.gz 279019 BLAKE2B cc1e59d0a34ccb4ce50c8a2982b308d23cd525ceb44d84a493c0fe9b5a6f7f616e8a4c440ae211fca811a2bf904ddb75d93618f3c6ac7bbe6b1ed022710dab1f SHA512 d454369fe1acb01c2210a61e15f45ac9cc77102c93345257f4ef3090bd8f31f1ccc49d9fd6ea670cddca9f715ad5db29368b4eecd95abff50d1033c4f7a967d6
DIST click-7.0.tar.gz 289077 BLAKE2B 0e180eeb1d7d9da34c33f95398c2b53dce124317bd2777ad545c1d4b4f3a96da0e281fac46c8fe6446848f25f7b705d2348d3ab6f5786219b4214650424ab260 SHA512 7ed2bf677f4a56f120deb61318675679a8f09c152af618e8808d24a20cc8537b0691c18b0de2e25b814c59e34b47d6f4d71191856422fc3be206de7669d78f3a
+DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a71ec65c0a8a144c7a0e244b5bdf0196ffe2150889b82edda20c3f1faa3c84a227fc9ef459a5a9646cff86129 SHA512 d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
diff --git a/dev-python/click/click-7.1.2.ebuild b/dev-python/click/click-7.1.2.ebuild
new file mode 100644
index 000000000000..e7dbf92c6e53
--- /dev/null
+++ b/dev-python/click/click-7.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}