summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-13 06:50:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-13 07:05:34 +0100
commit359b04992018ba493990ec84568637b32c60a630 (patch)
tree6e34a405b75077c9270010ac96bb2b1f71f7f633 /dev-python/denonavr
parentdev-python/markdown2: Bump to 2.4.8 (diff)
downloadgentoo-359b04992018ba493990ec84568637b32c60a630.tar.gz
gentoo-359b04992018ba493990ec84568637b32c60a630.tar.bz2
gentoo-359b04992018ba493990ec84568637b32c60a630.zip
dev-python/denonavr: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/denonavr')
-rw-r--r--dev-python/denonavr/Manifest1
-rw-r--r--dev-python/denonavr/denonavr-0.11.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index ec1de3562d9a..c0ac9105f536 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1 +1,2 @@
DIST denonavr-0.11.0.tar.gz 171742 BLAKE2B b91008a8eebcc0e228db772f2fe2d0bcd3fe7cc036d8aab2c547698224e63e0cbea2d9e9dcb5244556712ab5e04cb9c5e06731eba93a37061536668065c03931 SHA512 63624ec23db6e953741f4610a7df22fa0a69ae750957e883f0447c7a193c28e3a70245547f270c05bf93fdaca2c22b1fc5147b5e2b886c28049faf7f02b6bcb2
+DIST denonavr-0.11.1.tar.gz 173372 BLAKE2B a18bebfd66d1974b10e23f08fa2e2ca1ebef45ed29edf77ce9d68a26c657aebdc906bf10154d1a3ae94f1cb97ebe58a54434f3bba2510323a2a651e87f2e6987 SHA512 4354873577fbb021dee198a955c8fd89115c379c8e558ef827224a4dbdb2705edddcfa071cc42f923a12f9730b5a9adbfa85eae8f6f377357c854cb48a01d5e7
diff --git a/dev-python/denonavr/denonavr-0.11.1.ebuild b/dev-python/denonavr/denonavr-0.11.1.ebuild
new file mode 100644
index 000000000000..5ef6e71f8645
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest