summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-07 17:18:00 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-07 17:18:00 +0100
commit2829232366150eca34d75fb9e2ef537a9882fd41 (patch)
treef07d5baa028fc0a6b9f2f2677574741687a91973 /dev-python/httpbin
parentdev-python/anyio: Remove old (diff)
downloadgentoo-2829232366150eca34d75fb9e2ef537a9882fd41.tar.gz
gentoo-2829232366150eca34d75fb9e2ef537a9882fd41.tar.bz2
gentoo-2829232366150eca34d75fb9e2ef537a9882fd41.zip
dev-python/httpbin: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest1
-rw-r--r--dev-python/httpbin/files/httpbin-0.10.1-werkzeug-3.patch78
-rw-r--r--dev-python/httpbin/httpbin-0.10.1-r5.ebuild55
3 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index c095ce2f4c3f..f21fd6043cd9 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -1,2 +1 @@
-DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
DIST httpbin-0.10.2.tar.gz 107327 BLAKE2B 39ab1e518c9f7e1ede9cd0aa2e3155f7e36267c83d1d2537a5b6cb5aa1c9e70efe96c5bf98a5b22cd05e70368d1495f8e5364032fcf2f476d62512b7e7322652 SHA512 731b842090be516d9eccb1d2bb8303128d2b2e24b1ebf0b2018a2f0b8629b164c7de686e1775841cd57417ec89941d98fc81f878a284c7242bfef4db481a781b
diff --git a/dev-python/httpbin/files/httpbin-0.10.1-werkzeug-3.patch b/dev-python/httpbin/files/httpbin-0.10.1-werkzeug-3.patch
deleted file mode 100644
index 5ad6f2743400..000000000000
--- a/dev-python/httpbin/files/httpbin-0.10.1-werkzeug-3.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/httpbin/core.py b/httpbin/core.py
-index 5c1783a1..a82c1b88 100644
---- a/httpbin/core.py
-+++ b/httpbin/core.py
-@@ -32,7 +32,7 @@
- from werkzeug.wrappers import Response
- except ImportError: # werkzeug < 2.1
- from werkzeug.wrappers import BaseResponse as Response
--from werkzeug.http import parse_authorization_header
-+
- from flasgger import Swagger, NO_SANITIZER
-
- from . import filters
-@@ -47,6 +47,7 @@
- H,
- ROBOT_TXT,
- ANGRY_ASCII,
-+ parse_authorization_header,
- parse_multi_value_header,
- next_stale_after_value,
- digest_challenge_response,
-@@ -636,16 +637,13 @@ def redirect_to():
- args_dict = request.args.items()
- args = CaseInsensitiveDict(args_dict)
-
-- # We need to build the response manually and convert to UTF-8 to prevent
-- # werkzeug from "fixing" the URL. This endpoint should set the Location
-- # header to the exact string supplied.
- response = app.make_response("")
- response.status_code = 302
- if "status_code" in args:
- status_code = int(args["status_code"])
- if status_code >= 300 and status_code < 400:
- response.status_code = status_code
-- response.headers["Location"] = args["url"].encode("utf-8")
-+ response.headers["Location"] = args["url"]
-
- return response
-
-diff --git a/httpbin/helpers.py b/httpbin/helpers.py
-index b29e1835..836c8026 100644
---- a/httpbin/helpers.py
-+++ b/httpbin/helpers.py
-@@ -13,8 +13,14 @@
- import time
- import os
- from hashlib import md5, sha256, sha512
--from werkzeug.http import parse_authorization_header
- from werkzeug.datastructures import WWWAuthenticate
-+from werkzeug.http import dump_header
-+
-+try:
-+ from werkzeug.http import parse_authorization_header
-+except ImportError: # werkzeug < 2.3
-+ from werkzeug.datastructures import Authorization
-+ parse_authorization_header = Authorization.from_header
-
- from flask import request, make_response
- from six.moves.urllib.parse import urlparse, urlunparse
-@@ -466,9 +472,14 @@ def digest_challenge_response(app, qop, algorithm, stale = False):
- ]), algorithm)
- opaque = H(os.urandom(10), algorithm)
-
-- auth = WWWAuthenticate("digest")
-- auth.set_digest('me@kennethreitz.com', nonce, opaque=opaque,
-- qop=('auth', 'auth-int') if qop is None else (qop,), algorithm=algorithm)
-- auth.stale = stale
-+ values = {
-+ 'realm': 'me@kennethreitz.com',
-+ 'nonce': nonce,
-+ 'opaque': opaque,
-+ 'qop': dump_header(('auth', 'auth-int') if qop is None else (qop,)),
-+ 'algorithm': algorithm,
-+ 'stale': stale,
-+ }
-+ auth = WWWAuthenticate("digest", values=values)
- response.headers['WWW-Authenticate'] = auth.to_header()
- return response
diff --git a/dev-python/httpbin/httpbin-0.10.1-r5.ebuild b/dev-python/httpbin/httpbin-0.10.1-r5.ebuild
deleted file mode 100644
index d34c543e7976..000000000000
--- a/dev-python/httpbin/httpbin-0.10.1-r5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="
- https://github.com/psf/httpbin/
- https://pypi.org/project/httpbin/
-"
-
-LICENSE="|| ( MIT ISC )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test-rust"
-
-RDEPEND="
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/flask-2.2.4[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- test-rust? (
- dev-python/flasgger[${PYTHON_USEDEP}]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/psf/httpbin/pull/29
- "${FILESDIR}/${P}-werkzeug-3.patch"
- # https://github.com/psf/httpbin/pull/44 (simplified)
- "${FILESDIR}/${P}-optional-flasgger.patch"
- )
-
- # remove unnecessary deps
- sed -i -e '/greenlet/d' -e '/flasgger/d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- optfeature "Fancy index" dev-python/flasgger
-}