summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-21 16:22:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-21 16:32:46 +0100
commitbc23e0db0633a46e568ead3e1a1683c3508d1691 (patch)
treeab1575f59571b8a1c17447e7a2f83c64e210dbd7 /dev-python/humanfriendly
parentdev-python/humanfriendly: Drop old (diff)
downloadgentoo-bc23e0db0633a46e568ead3e1a1683c3508d1691.tar.gz
gentoo-bc23e0db0633a46e568ead3e1a1683c3508d1691.tar.bz2
gentoo-bc23e0db0633a46e568ead3e1a1683c3508d1691.zip
dev-python/humanfriendly: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-1.44.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 181fc6a525d7..61926296d9dc 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1 +1,2 @@
DIST humanfriendly-1.44.1.tar.gz 44281 SHA256 a9c545dc284c8e310465dba0b2300d898a9dc0d6eba5852f7578e03ff3ffc4ea SHA512 d5467e75c2e84c50dacaaab1c14b71a536eda5b91f4fc2d6ca69f1f1e50fe0ac215ac6cbf91cf7df08456f3058dcf84f0e38f611022c295e90c936e3b8a77cc9 WHIRLPOOL 869f86cd719fb9f3810767a37f43742ff21e9664229ccc4525873c84288fff8e9f08530796f54f2f1bea3b2df0601a424c5a253a42940c2d6a99cdbe19b20627
+DIST humanfriendly-1.44.3.tar.gz 44682 SHA256 910a01f17d73536d53f0464c3d825e64efcb56fff80c58b383b78bfab5f934d0 SHA512 7ddba207e9946ea38ec7d4aaebe87c38ae7cec0f87d7576a8e99425f9678e7b90d830de2518ba898ba485d86e4b363022a9919dbf4fdf0b6cdd4bcf1629cd1b5 WHIRLPOOL 58683b1085e92d0d9c24a9b31c189f20a6d04f9a0eed8369ef180d0e0e66bcf878c251d61dcce905ad53223b480e1d244ff239d56b5a13d730c48952ec85007a
diff --git a/dev-python/humanfriendly/humanfriendly-1.44.3.ebuild b/dev-python/humanfriendly/humanfriendly-1.44.3.ebuild
new file mode 100644
index 000000000000..eef8e504f86c
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-1.44.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ )
+ "
+python_test() {
+ esetup.py test
+}