summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-11 21:17:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-11 21:23:33 +0200
commita35326d7dd51f19e029d16de671d86a2b2646184 (patch)
tree43d20d86b944b6f86ff92e0a5140a7e5d8878137 /dev-python/pycares
parentdev-python/pallets-sphinx-themes: Bump to 2.0.0 (diff)
downloadgentoo-a35326d7dd51f19e029d16de671d86a2b2646184.tar.gz
gentoo-a35326d7dd51f19e029d16de671d86a2b2646184.tar.bz2
gentoo-a35326d7dd51f19e029d16de671d86a2b2646184.zip
dev-python/pycares: Bump to 3.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-3.2.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index abdf8a584040..a70bc1f15fde 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-3.1.1.tar.gz 216259 BLAKE2B 4481689e418695838c456f1e15b38dcdabadb106f393f52ec21a358b06621650d4e82086ca913abb341b9d8658db1c9ddd0064e68413e71a4ddded070647edfb SHA512 52c529510e3342c0b97ad0b4b9277d1f364da7719817a31a3cfac1f88613ea82f127182eab7c52c2fcd08008c689885bb4196f887a0f81b769f08f7cbf39909e
+DIST pycares-3.2.3.tar.gz 214612 BLAKE2B e06f45a8b8e9312596ff6a56262cc91c32cd578ea2dc4c54c0a9e52ec1aa1cb8174aa03c486c74c98bbc22e7801e231244e64a943d40407f7731fe00400723f6 SHA512 126c4cc1390b558da4ce82dfbd11c56ad6be038ce5eda93641548faa4a59cd81f08265b71de31d5b54238ccf8e7d937272c13611111b04230c6ee7e4f01cb8d8
diff --git a/dev-python/pycares/pycares-3.2.3.ebuild b/dev-python/pycares/pycares-3.2.3.ebuild
new file mode 100644
index 000000000000..dfc12ae28b0c
--- /dev/null
+++ b/dev-python/pycares/pycares-3.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${P/_p/-fix}.tar.gz"
+S=${WORKDIR}/${PN}-${P/_p/-fix}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+BDEPEND=${RDEPEND}
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}